Peugeot Forums banner

1 - 17 of 17 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1 (Edited)
Hello.
I am from sweden so you have to
excuse my English
I have a Peugeot 307 2.0hdi 2005 that does not start.
I have connected a computer and checked the live values.
I have error code 2670
The value of the fuel pressure sensor shows 1805 bar
We unplugged the cable but it still showed just as much.

We messure the cable between the couple and to the ecu and they were whole.
We measured the coupling, and there we had soil on pin 2.
5v on pin 1
and 1.5v on pin 3
In the computer program it said that it would be 0.5v on pin 3 but it is 1.5v
Sid803 is the ecu i think it was

Can it be a broken ecu?
 

·
Premium Member
Joined
·
2,672 Posts
Does it turn over OK? What is the cars history and when did the fault occur? Was it out of the blue or had it slowly got worse? It is difficult to diagnose with little info so as much as you can tell us will help.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #3
The start engine turns on and the motor spins but it wont start.
It has problem with the dpf. The tank for the injektion fluid is broken and has been for a while.
I have planned to re-map it to remove dpf and egr.
It has not charged anything from the turbo and has been in limp mode. It went as it always has in the last month and all of a sudden it just could not start.
I have owned it for 2 months
 

·
Premium Member
Joined
·
2,672 Posts
So first port of call should be the battery. Unless it is new it could be low on power. Although turning the engine it might not be enough revs to get it to self sustaining speed. You need to get your battery load tested. That means a test to check the amperage capacity of the cells. The voltage might check OK but its the energy of the battery that is needed. The tool they use is basically a load shunt or heat sink and has two battery leads and a dial which will show its capacity. They are on ebay and the type that is the best IMHO are the analogue earlier ones. They are not dear, at least not here in the UK .Peugeot are very sensitive to battery state so keeping the battery and the cars charging system, (alternator and belts) in good health is a must.
 

·
Moderator
Joined
·
7,915 Posts
Which engine version 90 bhp, 110 or 136
 

·
Registered
Joined
·
8 Posts
Discussion Starter #6
The battrey is ok.
It is a 136bhp
I think it is strange that it reads 1805bar even if I unplug the connector. And that it s 1.5v on The ecu when it should be 0.5v
 

·
Moderator
Joined
·
7,915 Posts
Unplug the EGR valve electrical connector and recheck readings/voltages at fuel pressure sensor
 

·
Registered
Joined
·
8 Posts
Discussion Starter #11
Its It's the same that sat there
The egr connector, were is it? Is it under the intake or behind the turbo
 

·
Premium Member
Joined
·
2,672 Posts
But is it the correct one as you have only had it for 2 months and the battery then fitted might not have been the correct one? If you google "307 2l hdi 136 egr solenoid valve" there is a photo of the valve. Its on the exhaust cover at the front of the engine bay or so it seems. Unfortunately the Haynes manual does not show it.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #13
Now it works. I unplugged the egr and the reading on The pressure dropped to 8bar. Then it just started.
Thanks for all input
 

·
Moderator
Joined
·
7,915 Posts
It's strange that in some circumstances the EGR valve fails and partly shorts one of the ECU power rails which throws the readings out on some of the other sensors.

I first encountered this on a non starting 1.6 HDI and thought it maybe worth trying on the 2.0 engine
 
  • Like
Reactions: madbadandold

·
Registered
Joined
·
8 Posts
Discussion Starter #17
It is the same problem now. The car drive for 2 weeks then it is the same problem it reads 1805bar bar. And I have the egr unplugged. I have download diagbox and try to fix it
 
1 - 17 of 17 Posts
Top