Peugeot Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
72 Posts
Discussion Starter #1
We have got an intermittant fault on the windscreen wipers on our Boxer Van. They operate for about 20 mins then stop. If we stop the van in a layby and start again, the wipers come on but stop again after 5 mins, tried all combinations of the wiper stock to see if the fault is in the stock switch but fault seems random. Van has done 55,000 miles and was one of the early "new style" vans which suffered from water pouring in through a badly sealed scuttle under the windscreen. Our van was resealed and various covers put in by the dealer to protect the wiper motor (DVLA recall)

Any suggestion as where to look for fault, so far I have identified a couple of possible areas, these being the fuses at the RHS of steering wheel and possible wiring loom going to the wiper motor but not found anything yet.

Many thanks
 

·
Registered
Joined
·
147 Posts
Does it work on the fast position? Mine packed in on the slow position but still worked on the fast. New motor sorted it.
 

·
Registered
Joined
·
72 Posts
Discussion Starter #3
Does it work on the fast position? Mine packed in on the slow position but still worked on the fast. New motor sorted it.
Just checked and wiper motor ran on single wipe, slow setting and fast setting and on off without problem then it stopped dead which makes me think it is some form of thermal trip or connection getting hot. It seems now that it wont work att all which is not a bad thing if I take it into the dealer.
 

·
Registered
Joined
·
72 Posts
Discussion Starter #5
Problem found

Hi, did you resolve this issue? I have something similar on my 407 thanks.
Hi, yes found the problem, I should have come back and posted what we found but could not reset my password at the time.

The fault was down to the multi connector plug which fitted onto the wiper motor. One of the pins was badly burned in both the motor and the plug which meant a new motor and new plug. Our local garage tried to buy a new plug with tails from Peugeot but Peugeot would only supply a complete loom but they managed to source a repair plug with 150 mm tails from a guy in Poland through eBay.

I think part of the problem was down to water getting into the connector due to the awful design of the bonnet and scuttle area of the Boxer cab. Water just poured in but although we got is "sort of " fixed it was a bit of a botch. Boxer 2007 was a pretty poor design in terms of Juddering in reverse due to bad gearbox design, creaking springs due to being under rated, Not fit to be taken out in the rain.
 
1 - 5 of 5 Posts
Top