Peugeot Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hi, my car has been fine, just been serviced two weeks ago.

Today I came to start it after 4 hours or so and when I turned the key the engine did not turn at all and the dash lights started flashing randomly almost like christmas tree lights, even the light on the air con button on the central console. I also heard a faint clicky clicky noise somewhere from the dash momentarily when the key was just left in the on position

I tried a few times, sometimes all the dash lights came on and stayed on, sometimes just the battery light. I tried jump leads on it but the behaviour was the same. As it was dark and wet I left it where it was and got a lift home.

So far from searching the internet, things to try when I go back in the daylight tomorrow are the spare key, check the terminals and the earth lead? is clean. Check fuses.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
Jump leads worked today, only difference is I attached the black to the body work of my car rather than the negative terminal.

Took it for a spin, turned it off had a cup of tea, then it started on its own fine.

Thoughts? Do I run straight out and get a new battery on Monday?
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
Thanks. What will that involve? If I take to the garage will they be able to tell me quite easily if the battery is knackered?

The indicator on the battery is green, I have been for another spin to get some petrol.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
Battery tested Mon morning as fine and been driving to and from work all week lights on etc ok.

Just done the same journey in daylight got out of the car for 2 mins dropping son at club and it's suddenly seems to be completely flat again ? ?
 

·
Registered
Joined
·
5 Posts
Discussion Starter #7 (Edited)
I used jump leads again but it was refusing too start for ages, not properly turning even though it was getting power as evidenced by display, head lights etc but it did randomly eventually start no issues indicated on the dash.

How ever on the way home when pulling off a stop junction something suddenly slowed the car, I immediately put it into neutral and accelerated thinking it was the engine after which it was okay but now the abs light and (!) light is lit. What is going on?

It did have new disks and brakes when it was serviced now three weeks ago. I did stop suddenly on the way to dropping my son off. Is it all linked?

Battery seems dead again after driving it home 15 miles.

Edit I could hear a faint beeping noise when pressing the brake.
 

·
Registered
Joined
·
15,377 Posts
Does sound alternator related as low voltages can put abs lights on but it may just be a bad battery/connection somewhere it needs tested by someone who knows electrics.
 

·
Registered
Joined
·
1 Posts
lawrie

my 107 has a flat battery the car does around forty miles a week is this enough running to keep the battery healthy ? Why does the owners manual suggest that the battery is disconnected if the car is not used for a month?
 
1 - 11 of 11 Posts
Top