Peugeot Forums banner

1 - 13 of 13 Posts

·
Moderator
Joined
·
11,978 Posts
In theory it should be reasonably OK if the wheel arch liner is fitted properly.

Am I right in thinking these have a plastic "bag" around them as well, or is that the horn or something else round that region (cooling fan relays?)
 

·
Registered
Joined
·
399 Posts
Discussion Starter #5
In theory it should be reasonably OK if the wheel arch liner is fitted properly.

Am I right in thinking these have a plastic "bag" around them as well, or is that the horn or something else round that region (cooling fan relays?)
A garage said the pump was fooked but if this was the case why does the fault go away and come back on when I hit a good pot hole?

I don't know about a bag around anything but its French :lol:
 

·
Moderator
Joined
·
11,978 Posts
I'd say its possible. Always check wiring or whatever you can for free before spending. Electrical contact cleaner is something every Pug owner should have in his toolkit, I've lost count at the things its fixed on my Pugs (mainly the 307)

Brake switch
MAF sensor
Lights
Horn
Fan relays
Indicator stalk
 

·
Registered
Joined
·
399 Posts
Discussion Starter #10
I'd say its possible. Always check wiring or whatever you can for free before spending. Electrical contact cleaner is something every Pug owner should have in his toolkit, I've lost count at the things its fixed on my Pugs (mainly the 307)

Brake switch
MAF sensor
Lights
Horn
Fan relays
Indicator stalk
Will WD40 be on to clean the contacts?
 

·
Registered
Joined
·
399 Posts
Discussion Starter #13
Just cleaned the plug out and the connectors but has not solved my problem :(
I have a abs pump off a 2004 reg hdi but the connectors are different so in still on the hunt for a new one that fits mine!
 
1 - 13 of 13 Posts
Top