Peugeot Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi all,

Hope somebody can help. I just bought a Sony XAV-601BT in Car audio system. Could anybody tell me if I will need to adapt the wiring loom or and hardware in order for the stereo to work? Is it just plug and play? I want to control the stereo on the steering wheel of my 307, if possible display info in the factory fitted display as well as it to look good. its a 2 DIN unit that will replace the factory fitted stereo.

Thanks all in advance,

Lee
 
P

·
Guest
Joined
·
0 Posts
Connecting stereo up shouldn't give you to much trouble. Getting the steering wheel controls require an adapter to get it working, easily available. Getting the display to work also requires an adapter but only seen a couple of these online and can be expensive.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Hi

Many thanks for your reply.

Do you know if the factory fitted radio is an ISO connection? I'm guessing the new stereo will plug in although steering control will not work without the adaptor?

Also, do I need a facia cover for the new stereo or will it sit in neatly as it is?

I haven't recieved the radio yet so can get the bits needed before it arrives if anything else is needed.

Thanks again
Lee
 

·
Registered
Joined
·
1,860 Posts
My 307 is a can connector so needed isi - din adapter, I think it's something like connect2 fer the wheel remote cable and you need an aerial adapter old unit has an amplifier booster it's a fakra type so you need to change it for yours and connect it too the aerial output from the new cd

My pioneer fitted straight in the gap, you get some of the display tools but loose radio station info

Allan


Sent from AutoGuide.com App
 

·
Registered
Joined
·
1,860 Posts
Forgot to say careful connecting the electrics pugs have a bsi board that you can upset if you do the job live, also make sure your radio signal is ok before you tidy everything up I had to remove my old fakra termination it would not connect so splice and joined the aerial


Sent from AutoGuide.com App
 

·
Registered
Joined
·
3 Posts
Discussion Starter #6
Hi all,

Thanks for all your advice,

I got the unit fitted and working using the autoleads pc99 patch cable & harness. And connected the Sony control patch cable to the black box on the loom as instructed, and now I have a powered unit with sound (which is always a goos sign!) but still have no control. If I press any button on the stalk, nothing happens, if I turn the scroll wheel on the stalk it returns the stereo to the home screen. So connection is there, but just not working correctly. Do you have any ideas what the problem could be?

Many thanks

Lee
 
1 - 6 of 6 Posts
Top