Peugeot Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
45 Posts
Discussion Starter #1
Hi all my s reg 806 has no flow in the header tank and occasionally a high pitched squeal is heard under the bonnet could this mean my water pump is up the spout ? Car temp reached 85 today as well
 

·
Registered
Joined
·
192 Posts
Could be, but as it's driven off the timing belt I'd be surprised. The impeller may have come adrift but I've never known this on one of these engines.
 

·
Registered
Joined
·
45 Posts
Discussion Starter #3
It's only just started doing it , I took cap off the bottle and started car left it running for about 10 minutes and saw no flowing of water in the header tank but when it does make the noise the level in the tank raises slightly ??
 

·
Registered
Joined
·
1,054 Posts
Impeller fell off whilst in France on the A7 some years ago doing 85, pump though remained intact, temp soared into the red, thank goodness we had breakdown insurance and 1,000 euros later at the Peugeot dealership in Besancon we were on our way. Think you need to replace the timing belt and check the pump sooner rather than later. 807 was losing a little water before this happened but I could not confirm where from.
 

·
Registered
Joined
·
45 Posts
Discussion Starter #5
If I take the small pipe off under the header tank with engine running it does have a flow of water I'm not losing any coolant but if you put engine under load Ie up a hill the temp does creep up ? I have new water pump so think I'm going to change anyway but I think the noise is possibly diesel pump
 
1 - 5 of 5 Posts
Top