Peugeot Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I just had a full service carried out and had 2 front springs fitted. Now when I drive I am getting a noise which appears to be coming from the front N/S about the bottom of the windscreen area/engine compartment? A further vibration is coming from around the CD player although it did make a creaking noise before so its maybe caused by the new problem.
I have had the air filter box tightened (reduced a lot of noise), removed the battery plastic cover, the springs checked for tightness but this noise just seems to come from no where and is at its worst on bumpy ground.
Any suggestions would be gratefully tried as I can not drive it much longer as its driving me mad.
Thanks
 

·
Registered
Joined
·
118 Posts
Could be related suspension components that have been damaged during fitting.
Particularly prone are the wishbone suspension bushes.

You can have a quick look by taking the wheel off (sill on an axle stand), and seeing if the wishbone has dropped or the bushes are split. If they are - new wishbones are easier than bush replacement for DIY.
It's not really the garages fault - just what happens sometimes.

Other thing may be the dreaded bottom balljoint - common fail point causing knocking over rough ground.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Thanks Richie for your advice.
I had the tracking checked as I saw some wear developing on the front N/S (new tyre). The garage said it was miles out and this has improved the noise but not fully eliminated the problem. The (tyre) garage said there was no obvious wear on bushed etc but I will have it checked properly to confirm this.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top