Peugeot Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
107 Posts
Discussion Starter #1
Hi All

I have a peugeot 307 2.0 hdi 90 2002 its done 161k and in the last 1800 miles the water level as dopped about 5mm ish i know its not a lot but its done it twice now im going to order a pressure cap but only seems to have started after changing tenp sensor "I THINK" should i just bung in some k seal anyone come across this. Theres no mayo.
 

·
Registered
Joined
·
3,423 Posts
mine comes from the water pump. even though its new it seeps a tiny bit. have a look underneath the car on the cam cover if you use red coolant you will see it easily.

the cap could be a problem or any pipework around the engine bay
 

·
Registered
Joined
·
1,424 Posts
mine comes from the water pump. even though its new it seeps a tiny bit. have a look underneath the car on the cam cover if you use red coolant you will see it easily.

the cap could be a problem or any pipework around the engine bay
+1 on these but the K seal is a No the pressure cap could be the cause they do get weak after a time
 

·
Registered
Joined
·
107 Posts
Discussion Starter #4
Can the water pumps on these be leaky is there any way to rectify, is k seal a problem on these cars.
 

·
Registered
Joined
·
1,424 Posts
water pumps can always leak slightly through the gland A small weep is nothing to really worry about I was losing coolant after a water pump/cambelt change and the new cap seems to have stopped it Some of the Jubilee clips can give problems

Ask any Mechanic and they would advise steering clear of K seal and any other product that can clog a waterway

Do A job Once correctly is always best in the long term
 
1 - 5 of 5 Posts
Top