Peugeot Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
i have just bought a 307 2.0 hdi.
very happy with the car but when accelerating up hills, there is a audible bleep and the message "unblock diesel filter" comes up on the display.
the garage have changed the fuel filter but the warning is still happening ,
any ideas?????????:confused:
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
they said they had , but i was more worried that it could be something to do with the particulate filter or addative level:confused: :confused: :mad:
 

·
Registered
Joined
·
256 Posts
PSA Australia tell me that the dealer/service tech's have to reset the computer after it is changed because there is no way that the system wil know that it was changed!!!
 

·
Registered
Joined
·
862 Posts
maddog said:
they said they had , but i was more worried that it could be something to do with the particulate filter or addative level:confused: :confused: :mad:

Go back to the garage and tell them to reset the ecu,if the light comes back on then you know you might have more bother.
 

·
Registered
Joined
·
945 Posts
its got nothing to do with the ECU chief.. its your particulate filter.. when was last topped up..

besides, you need to go to the garage and say that the error still remains.. They are too quick to replace the part but wash thier hands afterwards..
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7
I Am Going On A Motorway Trip This Weekend , So Hopefully That Will Clear The Filter, I Have Already Rang The Garage And Said That If It Is Still Hapening On The Way Back They Are Getting The Car Back Next Week To Go On The Computer At The Local Peugot Dealer (car Bought From Skoda Dealer). He Has Agreed That It Is Un Acceptable That The Warning Light Keeps Coming On And As It Is Under 3 Month Waranty He Will Do What Is Needed(i Dont Think He Realises The Potential Costs).
Watch This Space.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #8
Additive refilled and new filter fitted - now fixed, warning hasnt been on since. However indicators now dont work and terrible grating noise coming from front wheels, particularly bad on left hand bends, but can hear it going along the straight. Weld gone on lower wishbone bush, not sure if this is the cause, but watch this space.!
 
1 - 8 of 8 Posts
Top