Peugeot Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
103 Posts
Discussion Starter #1
2009 expert tepee 1.6hdi

Not used the van for a week or so but took it out for a spin today all was fine got nice and warm pulled up at a junction and needed to give it some beans to pull out (busy road and no one gives way)

So i pulled out and the turbo come on and was fine changed to 2nd yet again turbo come on but hesitated to pull (felt like it was jerking) and a bucket load of black smoke then all of a sudden smoke cleared and van pulled like a train.

So now if the turbo comes on and you dont try to much pedal all is good but if you do give it some pedal (i need to due to the hills around me) it hesitates and black smokes until you let off some of the pedal or drive through it then it clears.

Any thoughts ? looked at the turbo there is no side ways movement and very good oil supply.
 

·
Registered
Joined
·
103 Posts
Discussion Starter #3
Not got access to Diagbox and no one near me either so its find it the hard way did some google and it seems it could be a leak on the intercooler.

Shall whip it off and see if it has any oil or water in as google seems to think its condensation from the hot/cold air ?? and youtube suggests drilling a small hole in the bottom of the intercooler :nod: yup drill a hole.

The leak (idea) does seem to fit in with my symtoms all good until you demand lots of turbo and it not being given enough air hence over fuel.
 

·
Registered
Joined
·
1,805 Posts
You can expect some oil in the cooler, but if it's flooded then you need to look into why.

My first thoughts were EGR, but it is a total stab in the dark without looking at what's going on in the car.

If the way forward for you is elimination, maybe it's worth giving the manifolds, turbo and oil feed, egr, cat etc. a good once over.

Do you know if the van has a DPF?
 

·
Registered
Joined
·
103 Posts
Discussion Starter #8 (Edited)
Pulled wires of egr and it drove better than it ever has also no smoke at all so i guess it needs a clean out.

Edit took the egr off and the pin was rather stiff to move but after 10 mins in the sink with washing up liquid and some elbow grease i have it moving rather free.

 

·
Registered
Joined
·
1 Posts
I have the same problem nearly, black smoke under load, surging, poor fuel economy, I took some advice to unclip wires to mass air flow which I did and black smoke stopped, however this didnt mean the mass air flow was the problem as I changed it for a new one and its back to the black smoke, may try the egr valve either clean or block it off, how do I get to it please any help appreciated
 

·
Registered
Joined
·
2 Posts
check the oil flow to turbo urgently

My 2006 Partner just died. It had been doing exactly as you described and then one day the turbo started making a horrible noise. The shaft in the turbo snapped and bits of impeller went through the engine. On examination it was discovered that the oil flow to the turbo had failed. Therefore I would suggest you examine the turbo oil supply and get the whole oil system flushed. Good luck
 
1 - 12 of 12 Posts
Top