Peugeot Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter #1
Seems to keep getting niggly faults with my 307, been the bane of my lift since I bought it in March.....

Now the rear wiper randomly starts when I open unlock the car with the plip or when I open/slap one of the doors or boot (random). Its even wagging away when the neighbor locks/unlocks their far (sadly they too own a 307). What really bugs me though is the random position its stops it.

Read a few threads about the comms unit but kind of hoping its much simpler. I've had the rear inner pillar cover off to check the earth and clean up but looked fine. Taken the fuse out now as its driving me up the wall.

On top of this over the last week or so i've noticed the front end sounds/feels loose/rattly when going over uneven surfaces, perfectly fine on normally surfaces - normally would consider drop links but sure the dealer said he had just replaced these. No movement in either front wheel and 6/12 but there is at 3/9 both on and off the ground. Also when stationary turning the steering wheel side to side makes a clonk/click sounds. I know it could be many things but don't want to go throwing ball joints, drop links and track ends at it!!

Any ideas, and will the pain ever end............ :notsure:
 
P

·
Guest
Joined
·
0 Posts
I'm sure i saw a post on here where someone did a bsi reset and it cured a strange wiper problem...
 

·
Registered
Joined
·
3,426 Posts
you call that troublesome. i call it a saint lol :D

i would definitely try a bsi reset. sounds like the electrics are going haywire especially if it works off you neighbours key
 

·
Registered
Joined
·
28 Posts
Discussion Starter #5
Thanks for help, yes I had previously tried the BSI reset a few times but to no avail. Its just more of an annoyance to me if anything as I hardly use the rear wiper, just a bit embarassing with the stupid thing going off all the time....it's like an excited puppy greeting its owner!! Any chance it could be a faulty motor or is there a possibility it could be another earth connection??

Thanks davidireland, where am I looking for the anti rollbar bush mounts...i've noticed looking from wheel level there a word perished bush which lies flat which I think is the subframe bush. Only one side (OS) is worn, also the same side another rubber bush nearer the inner wheel looks a little worn -sorry my mech vocab isn't great!!

Cheers, Dale
 
1 - 6 of 6 Posts
Top