Peugeot Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
5,906 Posts
Discussion Starter #1
Started with the horn & aircon not working.

Horn was easily diagnosed by metering the horn and it was open circuit. Replacement unit from breakers yard fitted and now have a working horn.

The aircon seems to be a problem with the clutch. Engine running and the aircon button pressed, indicator light illuminates but the clutch doesn't engage. Suspected it might be a fuse so got to checking the fuses. Checked all the fuses on top of the engine compartment fusebox and all good. Disconnected the battery to make it easier to get to the bottom ones and all of those are ok. Next stop was to check all the fuses in the BSI and all checked out ok.

Everything reconnected and as expected, the time & date are flashing in the MFD. Plugged in the RD4 but cannot change anything. Press the menu button and the display shows menu but cannot scroll through the options. The navigation buttons work with the audio so it isn't the RD4 malfunctioning.
Tried a BSI reset to no avail.

PP2000 & Diagbox both show no communication to the MFD ECU.

So I guess it could be on of three scenarios

  1. Replaced a fuse in the wrong place (there are a couple of holders without fuses)
  2. A fuse has blown since I checked them
  3. I've somehow blown the display ecu
Anyone have anysuggestions ? The fuse listing in the Haynes manual doesn't seem to relate to the fuses in my car so cannot go off that information.

If it is the MFD ecu that has gone, is the ecu integral to the display ? If so then I could probably pick up the display from the same breaker I got the horn. The donor car for the horn was a 2003 307. Would that have the same display as a 2006 facelift version ?

Hope someone can help point me in the right direction

Thanks in advance
 

·
Registered
Joined
·
5,906 Posts
Discussion Starter #2
Had another look at the MFD and noticed that there are a few missing pixels on the top line so I'm guessing that the display is my problem.

Looking at the displays on ebay, it looks like the earlier models had a different display so they may not be compatible. The display in mine is a Johnson unit so I'll be looking round the local breakers for one.
 
S

·
Guest
Joined
·
0 Posts
Just an fyi, aircon clutch wont kick in if system pressure is too low (ie due to a leak) :thumb:
 

·
Registered
Joined
·
1,828 Posts
Just an fyi, aircon clutch wont kick in if system pressure is too low (ie due to a leak) :thumb:
Also won't kick in if outside temp is 3 or below
 

·
Registered
Joined
·
5,906 Posts
Discussion Starter #7 (Edited)
Just an fyi, aircon clutch wont kick in if system pressure is too low (ie due to a leak) :thumb:
Thanks for the info, guess I'll have to get the system checked out / regassed

Also won't kick in if outside temp is 3 or below
Somehow don't think I'd have been trying to use aircon at that temperature :)

There are three 307s in the scrappies on Cleveland Street, Birkenhead.
Thanks for the info but Birkenhead is a touch out of the way. Always there as a last resort though.

Looks like the earlier models used a Siemens display rather than the Johnson so I guess they aren't compatible
 

·
Registered
Joined
·
1,828 Posts
Somehow don't think I'd have been trying to use aircon at that temperature :)[/QUOTE]

Aircon is not just useful for cold air, it's good for demisting as well especially at low temperatures.
 

·
Registered
Joined
·
5,906 Posts
Discussion Starter #9
Aircon is not just useful for cold air, it's good for demisting as well especially at low temperatures.
True, my last couple of cars had buttons for demisting the screen which put the blower on high and switched on the aircon. The 307 however has little windscreen icons on the airfow, blower and temperature dials for demisting, the first two are unsurprisingly airflow to the windscreen and fastest blower speed but strangely the hottest temperature setting.
 

·
Registered
Joined
·
5,906 Posts
Discussion Starter #10
Now beginning to think it could well be the RD4 that is faulty.

When I connect the radio, the display doesn't show the frequency or channel name. Also no CD information is shown in the MFD. So this makes me believe that the RD4 isn't communicating with the MFD.

The MFD does have about 3 pixels that aren't working but these are on the top row of the top line so I can live with it. Would dearly like to get the trip computer showing miles and gallons rather than liters & Km's though.

Anyone got a spare RD4 I could use to check and if proves the RD4 is faulty, possibly buy ? I'm willing to travel a reasonable distance.
 

·
Registered
Joined
·
5,906 Posts
Discussion Starter #11
Finally sorted it out

Was having another look at it again today and decided that my original diagnosis was correct so I phoned a local breakers and they had one in.

Took a chance and handed over £30 and plugged connected it while still in the breakers carpark. Connected up the RD4 and it worked. Was able to reset the display to MPG, set the time & date and set the display to miles instead of Km. Now a happy bunny.
 
1 - 11 of 11 Posts
Top