Peugeot Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
182 Posts
Discussion Starter #1
My temperature gauge is not working and only luke warm temperature comes out the heating when on max. I presume this is a thermostat issue? :confused:

If I drive for say an hour on the motorway, get stuck in traffic, the temperature gauge then starts to move and the heating warms up. :confused:

Also I can hear clicking noises from behind the heating vents like it's straining..? :nono: So vent issue also?
 

·
Registered
Joined
·
129 Posts
No I haven't. Which ones do I feel? which should be hot? Thanks
The big fat ones off the Rad, top one will get hottest, bottom one should also be warm if water is circulating.
Not sure on your engine layout so don't know if you have access to heater pipes in engine bay, they are usually in there.
Don't do this with engine running, little fingers.:eek:
 

·
Registered
Joined
·
1,132 Posts
If you had an air lock surely it would overheat on a motorway speed trip of any distance.
You are describing the classic symptoms of a thermostat stuck open.

Roger.
 

·
Registered
Joined
·
182 Posts
Discussion Starter #6 (Edited)
Had to go on an hours drive today. Again the temp gauge and also the oil temp gauge wasn't working. Luke warm air from vents. Strange though if I put the setting of the heating to the windows only, the temp coming from it that is nice & toasty. After about an hour both gauges started to work. Turn heating off and temp gauges drop back to zero.

Hmm.....
 

·
Registered
Joined
·
182 Posts
Discussion Starter #7
All sorted :thumb:

Garage did small service & changed the thermostat. Now got temp gauge working and nice toasty heating. The oil temp gauge still not working but, hey, who needs that really :confused:

:lol:
 
1 - 7 of 7 Posts
Top