Peugeot Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1 (Edited)
I have a 2016 Peugeot Partner BlueHdi with 85000km on the clock and with temperature problem. When i drive the car without the A/C temp is at 90°C. When i switch the A/C on while driving and go for an overtake or go uphill the temp goes to 110-120°C and when i switch it off to prevent overheating damage temp goes down to 90°C. I also have a problem with A/C, it works when the engine is cold for first 5 min of driving and then it blows hot. Also cooling fan frequently turns on the high speed to cool down the mess. I checked the A/C at the aircon specialist, he just filled it up with gas and he said that the A/C system is holding vacuum and the comressor is ok. That was 2 weeks ago. A/C behaviour didnt change. Then i went to the official peugeot dealer today and the A/C had around 230g out of 450g of gas and its still not working. I read here that A/C compressor has a sensor that prevents it from damaging itself and switches it off if there is not enough gas or if the compressor gets hot. So engine gets hot = A/C compressor shuts off. Official Peugeot dealer scanned the whole car with diagnostics and didn't find a single fault. What can I check next? I have a FAP app and ELM327 but hey if original pug diagnostics didn't find anything wrong i dont see how i can find anything else. Can it be that something is plugged in wrong?
 

·
Registered
Joined
·
10 Posts
Discussion Starter #2 (Edited)
Update - today I ran the van hard for 50km without the A/C, and I didn't have any engine heating issues. When I turned the A/C on it worked well for a few min and then it started blowing hot air and the engine temp shot up. I mean the car is not a high mileage one. I even checked to see if the engine has some blowby, it has none. This car is making me mad for sure. I had 2007 Peugeot Partner 90Hp 1.6 Hdi for 12 years and the A/C was ice cold the whole time i had it, and i am pretty disappointed about metal thickness old one was built like a tank and had a pretty satisfying sound when you close the door. New one is made from tin cans.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #5
I fixed the problem myself. When I took the car to the peugeot dealer a few months ago for a cooling fan change because the old one was going out, I guess one of ''techs'' that work there plugged in the cooling fan the other way around :mad:. Fan was pulling out the air from the engine bay and not pushing it in the engine bay. First I used FAP app with ELM327 and i discovered that the car was in ''safe mode'' - car was trying to cool itself using the 2nd AKA the high fan speed almost always. Then when I tested the wires it turned out that the engine fan was plugged in wrong. A\C works fine now, engine temp is solid at 90°.
 
1 - 5 of 5 Posts
Top