Peugeot Forums banner
1 - 9 of 9 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hi Guys,

Wondering if someone could help me, got peugeot partner 2003 2.0 hdi 42,000miles.
When I am driving, sometimes the temp sensor will shoot up from 80-90 to the red mark and the stop light will come on, after I pull in and turn the engine off and start it back up after about 10 seconds it goes back to were it was (80-90), has anyone any idea what could be causing this, the water level is ok, not losing any water.

Cheers
 
G

·
same on my 307, i've got a new temp sensor to put in but havent got round to it

FYI you dont have to stop the engine, it will return to normal after a short time!

I'm planning on swapping the temp sensor this weekend so will let you know :thumb:
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
Stubbo said:
same on my 307, i've got a new temp sensor to put in but havent got round to it

FYI you dont have to stop the engine, it will return to normal after a short time!

I'm planning on swapping the temp sensor this weekend so will let you know :thumb:
thanks very much Stubbo
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #4 ·
Stubbo said:
same on my 307, i've got a new temp sensor to put in but havent got round to it

FYI you dont have to stop the engine, it will return to normal after a short time!

I'm planning on swapping the temp sensor this weekend so will let you know :thumb:
How much did it cost for the temp sensor?, if you don't mind me asking.
 
1 - 9 of 9 Posts
Top