Peugeot Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi I wonder if you can help. My wife's 2008 207 runs perfectly except that in the last week the temperature gauge stays at zero, not rising even after half an hour. The air from the heaters is cold also.

Anyone got any good ideas as to what might be the fault? It's pretty tricky as the weather's getting colder and I'm worried that she won't be able to deice the car.

Many thanks

Boog
 

·
Registered
Joined
·
15,377 Posts
If there is no heat from the heaters you NEED to fix that pronto as your engine may well overheat

Check the coolant level as it may have sprung a leak if it leaks too much the heater will go cold and the temp gauges need coolant touching them to give a reading so it may well be connected.

DO NOT drive it or you risk killing the engine.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Thanks for that reliable407 - I've just checked the coolant levels and they're spot on. Appreciate the advice though.
 

·
Registered
Joined
·
1,132 Posts
Almost certainly the thermostat has stuck open. Next time you start the engine from cold have the bonnet open and see if the hose from the engine to to the radiator gets warm straight away. It should stay cold until the engine is showing near normal on the temperature gauge, then get hot suddenly as the thermostat opens.
Apart from no hot air for the heater running overcooled will cause rapid engine wear and bad fuel economy. If the thermostat is bad get it fixed asap.

Roger.
 
1 - 4 of 4 Posts
Top