Peugeot Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
80 Posts
Discussion Starter #1
Hi all,
When I switch on the off side indicator to turn right it flashes about three times then stops and the side light comes on, the near side one works fine.
When I say side light I mean just the one side light in the off side front headlamp unit.

Any ideas!!!
 

·
Registered
Joined
·
80 Posts
Discussion Starter #3
while it *might* be something BSI, I'd start by checking grounds and bulbholders...
Thanks dpmiller,

I have a side light and fog lamp out on the other side (nearside front) I think I'll try new bulbs in there 1st as knowing what french electrics are like anything could happen with a bulb out, then I'll go for the grounds.
 

·
Registered
Joined
·
80 Posts
Discussion Starter #5
check all wires for obvious signs of deterioration that will cause shorts etc.
Replaced all faulty bulbs all lights working ok, switch on offside indicator with lights off flashes 3 times then sidelights come on and indicator goes off.
Switch sidelights on and then offside indicator all works ok.

Have checked and cleaned earth behind headlamp unit and done a visual check on all the headlamp wires, no signs of damage.

I all seemed to start after I switched on the auto headlights.
 

·
Registered
Joined
·
80 Posts
Discussion Starter #6
Tried disconnecting offside headlamp unit and offside rear light cluster one at a time but even with each one disconnected it still switches on sidelight after 3 flashes.

Also tried switching on and off auto headlights again but still the same fault.
I think it's time to put planet on to see if there are any fault codes.
 

·
Registered
Joined
·
80 Posts
Discussion Starter #7
Planet shows no faults, but I noticed if you push the indicator stalk up till just before it clicks the indicator works fine if you push it up till it clicks the indicator flashes 3 times then the sidelights come on.
So it looks like it could be a faulty stalk assembly, so it looks like a trip to the breakers for another one.
 

·
Registered
Joined
·
80 Posts
Discussion Starter #9 (Edited)
Did you try a BSI reboot by removing battery cable for 5 mins?


Sent from my iPhone using AG Free
bettyswollocks,

Yes I tried that but still the same fault, I have since found an ad on ebay quoting cost of repair for some of the stalks.

Below is a copy of the ad it mentions the faults that can be expected for the model of stalk you have.

HOW TO FIND OUT WHAT UNIT YOU HAVE
it will tell you on the back of the unit its molded into the plastic when it was made
read the common faults list below

COMMON SYMPTOMS OF A FAULTY DAV UNIT
horn not working
when you indicate right and it clicks off does it puts the left indicator on itself
indicator feels loose
when you put indicator on if flashes full beam lights (blue ligh on dash)


COMMON SYMPTONS OF A FAULTY DELPHI OR VALEO UNIT (I CAN NOT REPAIR)
indicator clicks 3 times and then puts lights
head lights randomly come on (green light on dash)
 
1 - 9 of 9 Posts
Top