Peugeot Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi all. I've read through all the 'Partner' pages and also searched for any posts with the word 'STOP' in them but I haven't been able to find an exact duplication of the problem I'm having with our Partner Escapade.

When decellerating (as you do when you are slowing down to make a turn), the red STOP warning light flashes on and off and beeps. At the same time the handbrake light comes on AND the indicators, if they are on, stop flashing outside the car (the indicator relay switch stops making that tick - tick -tick sound) but the indicator arrow on the dashboard keeps flashing. This can last from 2 seconds to 10 seconds. Sometimes it doesn't happen at all. It's dodgy because a number of time I've been in the middle of a busy A road trying to make a turn across traffic flow and the indicators stop flashing. We've had all the switches on the steering column replaced, that cured a problem we previously had of the indicators not self-cancelling but still the handbrake light and the beeping and the STOP sign come on.

Today our very excellent local garage tried out a BSI reset procedure but this doesn't seem to have made any difference. Since then I've been advised to check hydraulic fluid levels as I'm told if they get too low, they can trip the sensor when going round a corner or braking.

Does anyone have any ideas?

Thanks

PS, I have a link to the BSI reset procedure, but I can't post it until I've made 5 posts.
 

·
Registered
Joined
·
1 Posts
STOP handbrake indicator probs when slowing/turning Partner

Hey all. In the past two weeks, Ive received the dreaded "STOP" indicator twice, both times with the message BRAKE FAULT. Rotors and pads are fine, brake fluid level was fine when I checked over the weekend, so Im not sure whats up. I will look more into testing this low level indicator/switch, but I wanted to know more about this "ABS street test." Ive been searching the forums, but cant seem to find it. Anyone can help? Many thanks.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Hello folks

The mystery is finally solved. It was oil pressure/level. I had been topping the oil up quite regulalrly but eventually a huge oil leak developped and on further investigation, it turned out there was a hole in the oil filter. Once the oil filter had been replaced and new oil added, all the previous symptoms disappeared.
 
1 - 3 of 3 Posts
Top