Peugeot Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter #1
hi all my 307 05 reg hdi , set off this week in morning stiff steering then 3/4 mile releases and steering as normal any ideas ?? Pete
 

·
Moderator
Joined
·
5,881 Posts
Check the condition of your battery and then the connections on the electric power steering pump in the drivers wheel arch
 

·
Moderator
Joined
·
11,780 Posts
Make sure the reservoir is overfilled beyond the MAX mark.

And give the electrical connector on the pump a good clean. It should be behind the drivers wheel arch.

I did that on mine and it made a massive difference.
 

·
Registered
Joined
·
20 Posts
Discussion Starter #4
I have ?

had look this weekend I tested alternator 15 v tested battery all ok , removed the connectors to pump cleaned with electrical spray , topped up just above max on reservoir , im I thinking oh no the pump gone a Burton ??
 

·
Registered
Joined
·
11 Posts
Fuse box

Look Under the fuse box near the battery in the engine bay.

There is a second layer of maxi fuses, one of which supplies the power steering.

The blade fuse will be corroded/ burnt and not allowing full current, therefore disabling your power assist

Remove the fuse, clean it up. Disassemble as much of the maxi fuse arrangement as you feel confident with and clean the contacts to bring it back to new again.

Photo the fuse positions so you don’t lose track of what goes where.
 

·
Registered
Joined
·
20 Posts
Discussion Starter #6
no luck

thanks for the advice still no luck cleaned all the fuses they were in good condition but gave them the ounce over still no luck I think its going be new pump ? I have noticed after 1/2 mile the steering snatches and happy days back to normal not sure if its when the power get built up or the fluid warms up ? if I do change the pump can I clamp the tubes ? Pete
 

·
Registered
Joined
·
20 Posts
Discussion Starter #9
Pump Fluid replacement

Could any body give me a bit direction on draining the steering fluid on the pump and replacing bon weekend
 

·
Registered
Joined
·
1,905 Posts
Disconnect the pipes at the pump after gaining access to the RH wheel arch. Windscreen washer fluid reservoir removal is required. After it has finished draining reconnect and refill the system. Start engine and let it idle for 3 minutes topping up to full as required. Then operate the steering lock to lock until the fluid stops bubbling adding fluid as required. Repeat until the level remains stable. Switch off an let it cool down and then final check to ensure level is full.
 

·
Registered
Joined
·
20 Posts
Discussion Starter #12
thanks

thanks Gibbo for advice no luck on cleaning connectors on pump or large fuses I going give a flush tomo as my final idea before new pump
 

·
Registered
Joined
·
20 Posts
Discussion Starter #13
fixed

hi all thanks for the advice I changed the pump with a second hand one from scrappy code matched on the pump all ok just keep informed for the future thanks again Pete
 
1 - 13 of 13 Posts
Top