Peugeot Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi all, I recently bought a 1999 (T Reg) Peugeot Partner van. At first it seemed okay, but I noticed that the speedo is sticking just over 40mph mark on the dial! It seems to work when I am doing below 40, which is odd. Any ideas?

Also the steering is really heavy, especially when turning slowly! I checked in the handbook to locate the power steering reservoir, but it doesn't seem to have one (well it's not in the place indicated in the handbook!) Stumped! I assume it is electrical or belt driven? It's a struggle for me cos I feel like conan the barbarian by the time I reach my destination, and big muscles don't look good on a girl!

Have also just discovered that the heater/blower, works on the windscreen setting, but when I change the dial to face etc, nothing comes out of the vents and the fan starts to make an almighty racket!

Any help you can give this damsel in distress would be most appreciated.

Got the van booked in for a full service on Tuesday and want to know possible solutions to these problems so I don't get ripped off, as it happens frequently to me at some garages!

Thanks all..x
 

·
Registered
Joined
·
4,506 Posts
in worse case scenerio:

- speedo could need new cluster
- steering could be power steering pump - keep looking for the reservoir, typically hidden low down, has a black cap that twists off.
- blowers will need new flaps installed
 
D

·
Guest
Joined
·
0 Posts
Remove the blower motor and actually have a look at it. The problem should be obvious.
As regards the speedo, it sounds like a clocks problem. Check the gearbox earth also.
The powersteeing problem is most likely the steering knuckle out in the engine bay. They have a tendancy to partially seize. Check the p/s fluid also. There is a reservoir attached to the top of the p/s pump. If it is empty, fill with ATF.
 
1 - 3 of 3 Posts
Top