Peugeot Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
please help !!!! I'm having problems with my peugeot 407 sw, I'm getting spurious faults coming up on my display , break fault , abs fault ,abs illuminates on the dashboard, seat belt tensioner fault , air bag fault , speed control fault depollution fault , i loose my speedo it drops to zero and the miles display goes red and the stop light comes up , if i stop the car it all resets then maybe comes on after 30 or 40 miles , or sometimes doesn't go into fault for a week or so , I've recently had new brake pads fitted on the rear of the car , and a full service carried outand an M.O.T , all be it not at a peugeot garage, any help would be much appreciated , kind regards a very worried peugeot owner !!!
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
cck2k9 said:
you may have to get this hooked up to planet to pin point...
Hi there I've had my car hooked up to the computer and it says "steering angle sensor" any ideas where it is , what it is and how much ???
 

·
Registered
Joined
·
6 Posts
Discussion Starter #4
karleezoe said:
Hi there I've had my car hooked up to the computer and it says "steering angle sensor" any ideas where it is , what it is and how much ???
Hi there , i'm still having problems with my car, a couple of times when i've turned the key off the engine has carried on running ? when i went to it today it wouldn't start at all battery was flat . I've charged the battery and it started first time , I'm getting the battery and alternator tested tomorrow morning , has anyone have any idea if a dodgy battery / alternator would cause all the spurious faults i've been getting ?? kind regards
 

·
Registered
Joined
·
6 Posts
Discussion Starter #6
bettyswollocks said:
Car keeping running is i think to do with the pump they should know this its well known in Dealerships,

Hi there do you know of anyone with peugeot planet in the cumbria area ??
 

·
Registered
Joined
·
6 Posts
Discussion Starter #8
Hi , changed the battery and the faults are still appearing intermittantly !!!! i'm getting it connected to peugeot planet this week hopefully !!
 

·
Registered
Joined
·
6 Posts
Discussion Starter #9
karleezoe said:
Hi , changed the battery and the faults are still appearing intermittantly !!!! i'm getting it connected to peugeot planet this week hopefully !!
Hi There
I've had the car connected to peugeot planet, the fault appears to be the abs unit is on its way out , or the wiring connecting the abs unit to the ecu because the communications are failing, I have had a play with the wiring and removed the plug connecting to the abs unit and refit it and the fault cleared for a nearly two weeks , now the fault is back !!!! i'm after any advice !!! the cable from the abs unit appears to go under the abs unit around the back of the battery box and into the engine ecu , does anyone have any idea where it goes so that i can bell out the wiring ?? is it one of the removable plugs?? I haven't tried to take the unit apart(I'm a bit of a novice with cars !!!) it seems to disappear into the bottom of the unit !! any advice would be much appreciated !!!! cheers kev
 
1 - 9 of 9 Posts
Top