Peugeot Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
45 Posts
Discussion Starter #1
Hi guys I have a s reg 806. 1.9td and the speedo sometimes works and sometimes doesn't is there a sensor on the gearbox or back of speedo cheers
 

·
Registered
Joined
·
192 Posts
It's driven from a sensor on the back of the gearbox but no doubt will have something on the speedo head as well.
 

·
Registered
Joined
·
45 Posts
Discussion Starter #3
Im hoping the cog that connects speedo to gearbox is ok because it does work sometimes I took the clocks out but I don't remember unclipping a speedo cable ,
 

·
Registered
Joined
·
45 Posts
Discussion Starter #5
Does it not have a sensor at both ends to
send and receive the signal from gearbox to clocks ?
 

·
Registered
Joined
·
291 Posts
I had the same issue with my 806 many moons ago, the Rev counter was he same.

I took the clocks out and on the back is unit that has all the cogs etc in, mine was clear plastic so easy to spot. The centre spindle that one of the cogs sits on had snapped, I carefully took the cogs off making note of how they were fitted and with a pair of tweezers some super glue and a very steady hand, glued the spindle back on. Left it for a few hours to ensure glue had cured properly then carefully reassembled, it lasted many years and never gave me any more issues

I also plugged the clocked back in without the front plastic screen on and took it for a drive with the sat Nav on so I could make sure it was showing the correct speed, had to remove he needle and reposition a few times before it was spot on.
 
1 - 8 of 8 Posts
Top