Peugeot Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I have a 52 plate 1.4 lx speedo not working, I've fitted new speedo and new speedo drive on gbox but still nothing can anyone help?
 

·
Registered
Joined
·
673 Posts
I have a 52 plate 1.4 lx speedo not working, I've fitted new speedo and new speedo drive on gbox but still nothing can anyone help?
i dont know how they work on this model but if you have changed the speedo and the drive would it be worth considering the cable..(if they use cables on this car)...:eek:
 

·
Registered
Joined
·
4 Posts
I have a 52 plate 1.4 lx speedo not working, I've fitted new speedo and new speedo drive on gbox but still nothing can anyone help?
Did u get this fixed , mines just stopped working but it happened after I cleared abs fault light with snap on scan tool, think it did something to bsi unit
 
D

·
Guest
Joined
·
0 Posts
The speed is taklen off the ABS wheel speed sensors. The front ones to be exact.
Get a diagnostic check done.
 

·
Registered
Joined
·
4 Posts
The speed is taklen off the ABS wheel speed sensors. The front ones to be exact.
Get a diagnostic check done.
I read in the Haynes manual and some where else that the 1.4 petrol was the only 307 in the range that didn't take it's speedo signal from the ABS sensor's but strangely enough this only started when I cleared the abs fault with snap-on mts 2500 scan tool I'm thinking it's done something to the bsi any ideas thoughts or suggestions PLEASE
 
1 - 5 of 5 Posts
Top