Peugeot Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter #1 (Edited)
Hi, I'm hoping someone can help me on this one. For a few months my wifes Peugeot 307 2.0 Petrol 2003 has displayed error code P0410 (Intermittent Fault. Injection of air the the exhaust Malfunction). More recently a second error has appeared and the engine light has come on. P0420 (Permanent fault. Catalytic converter ageing Loss of Effectiveness). The car splutters when cold start and cuts out if you start driving too soon without giving it some acceleration. Also it smells of unburned fuel and I think its using too much, although this is hard to tell for me as I drive a diesel which does around 45mpg.

I have done some searching online and have figured out that I needed to test if the secondary air pump was turning on when the car was cold for the 100 seconds. I've done this by connecting the pump directly to 12 volts for a few moments and found out that the pump is indeed working fine. However how do I diagnose the next item? I have blown down the hose coming from the pump to the engine(or whatever it connects to) and while the car is off, the hose seems completely blocked, I can't blow anything down it at all. Should this be so? Or should I be able to blow down it? Or should some sort of valve open to allow the flow of air once the engine is running?

Thanks for your expert help.


Warren

I've started the car and tried blowing down the pipe that the fan is blowing down during the 100 second cold startup. I found it very difficult to blow down the tube feeling little or air going down the tube and doubt very much that a fan would be able to put as much pressure down the hose as my lungs could. So would I be right in saying there should be some sort of switch that opens the air way?
 

·
Registered
Joined
·
2,195 Posts
Pump and air injection valve linked to pipe to exhaust manifold and various interconnecting air hoses is what the system consists of. Obviously the ecu is involved as per watching the temp and the time. Pump only runs at start when the engine is below a certain temperature and only for a short time between 10 and 45 secs. Just blowing down it with the valve shut would give you the symptom you have got.
 

·
Registered
Joined
·
9 Posts
Secondary Air Pump Fault.

I had fault code P0410 displayed and fuse 16 (30A) blown. On removal and dismantle of the secondary air pump I found a broken blade on the fan and the 2 broken pieces were jammed in the pump. On close inspection I noted scratch marks on the body of the pump where the fan blades had been contacting it. There was no perceptible play in the bearing so it appeared that the fan rotor was not positioned precisely at the centre axis.
I am wondering if this is a known problem with these pumps.
The pump is marked P.S.A. 96 533 405 80 Johnson Controls 21598727.
 

Attachments

1 - 4 of 4 Posts
Top