Peugeot Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I've had a 308SW 1.6 Diesel (15) for a few months now and I like the car, but the sat nav is showing me miles away from where I am. It was intermittent at first but now it's all the time. Upgrading the maps didn't help and although I don't really need it much it would be nice to have it working properly. Any suggestions would be appreciated.:lol:
 

·
Registered
Joined
·
978 Posts
This could be expensive. My C5 did somewhat of the same thing (the satnav was also by Magnetti Marelli) and showed me driving through the Irish Sea. The dealer ending up replacing the e-Myway head end unit (radio/satnav, etc) - under warranty fortunately. I believe that otherwise it would have cost the thick end of £1000.

The 308 has also had the SMEG+ unit replaced but for a different reason. Again under warranty. It does seem that there might be a question about MM's reliability. Possibly why PSA have moved away from them?
 

·
Registered
Joined
·
542 Posts
I've had a 308SW 1.6 Diesel (15) for a few months now and I like the car, but the sat nav is showing me miles away from where I am. It was intermittent at first but now it's all the time. Upgrading the maps didn't help and although I don't really need it much it would be nice to have it working properly. Any suggestions would be appreciated.:lol:
Have you tried to do a soft reboot whilst the system is on?
Have you checked the connections are ok at the back? Aerial maybe? Does the DAB work ok?
 

·
Registered
Joined
·
2,339 Posts
Mine did that once, showing me about 5 miles from where I knew I was. I had stopped for a break and when I started up again it was like that. Next morning it was back to normal. Never done it since.

Mind you, it's no worse than sitting on a ferry, about 1 hour south of Newhaven and getting a message on the mobile saying "Welcome to Iceland".
 

·
Registered
Joined
·
46 Posts
I've had a 308SW 1.6 Diesel (15) for a few months now and I like the car, but the sat nav is showing me miles away from where I am. It was intermittent at first but now it's all the time. Upgrading the maps didn't help and although I don't really need it much it would be nice to have it working properly. Any suggestions would be appreciated.:lol:
Check this thread, might be your gps receiver is failing.

I replaced mine with a dirt cheap one, easy fix and worth a shot..

https://www.peugeotforums.com/forums/308-2014-122/2014-308-post-facelift-gps-issue-334348/
 

·
Registered
Joined
·
1,888 Posts
I have read on these forums somewhere in the past that this can also be caused by a faulty ABS sensor on one of the front wheels. I know it sounds unlikely but apparently the satnav GPS location is determined by an ABS sensor on the front wheels.
 

·
Moderator
Joined
·
5,983 Posts
The wheel speed is only used by the satnav when it has no lock on the GPS to guestimate the vehicles position based on distance travelled from last lock.
 

·
Registered
Joined
·
46 Posts
I seem to have the same problem as you had so I'm going to try the same solution. I'll let you know how I get on.:lol:
well, for what it's worth, I never took the thing out again or stuck the cables down with cable ties..
Just let it sit there the same way it sat when I first magnetically stuck it onto the roof.
It works and I'm very happy I managed to fix it with a £8,- part.. :)

Always worth a shot, with amazon nowadays if it proves not to be the issue, you can always return it for a full refund..

Hope yours will work out too...
 

·
Registered
Joined
·
3 Posts
Discussion Starter #11
So I got the part this morning, 10 minutes to fit it, works great, jobs a good un.Total cost £4.99. Thanks to all for the help, well chuffed because I could have lived without it but getting it fixed for under a fiver is a great result. Happy days:lol::lol:
 
1 - 11 of 11 Posts
Top