Peugeot Forums banner

1 - 20 of 53 Posts

·
Registered
Joined
·
95 Posts
Discussion Starter #1
Hi everyone , long story short but had car put on Peugeot planet last week as engine light on and anti pollution fault , came back with permanent egr fault p0400 so over weekend I tackled the dreaded task of replacing as mine is the 110 307 hdi at back of engine , after 2 solid days it's all back together with brand new pie burg egr valve , after I fitted and got running I see lights still on ... So cleared all faults using my personal scanner , go out today on good 100 mile drive and bam it's back again !! No limp home mode thank god but got home gave a scan and the same code has reappeared p0400 , I didn't see much difference when changed to be honest but thought better change to get rid of fault... Can anyone help me why this is back again !! also since of had car for last few weeks it seems not perfect with boosting , sometimes it feel a bit restricted through rev range .. Don't know if helps ?
 

·
Moderator
Joined
·
11,780 Posts
There's more than just the valve in the EGR system.

Did you run live data and check operation of the parts or just read the code and swapped the EGR valve?
 

·
Registered
Joined
·
95 Posts
Discussion Starter #4
Hi he ran pugeot planet and it only came back with permanent egr fault so he told me to change egr or clean it so I thought il bite the bullet and buy new one ? What other parts are there that could be still causing this
 

·
Moderator
Joined
·
11,780 Posts
The parts which operate the EGR valve - vacuum solenoids, vacuum pipes, electrical connections to name but three.

We go on and on and on at people not to throw parts at a fault code.
 

·
Registered
Joined
·
1,045 Posts
for the price of the EGR part you could have got a blanking plate installed,

if its coming up with a permanent fault it could be a wiring fault you say its a 110 so is it a 2.0 or 1.6 HDi?

if your getting lack off boost from the turbo I would be looking at that valve but check for leaks as they all run from the same vac pump and if it leaks then it will cause low vac for the other valves like EGR, Turbo, Air dosers, and brakes
 

·
Registered
Joined
·
14,625 Posts
Using a vacuum gauge or boost gauge this will give you the readings for vac you need to go through ALL the vac system not just the EGR part

Depending on the gauge you are looking for a reading at -20 and stable when revved

Solenoids are a common failure too

Hdi 110 egr valve rarely gives trouble in itself

1.6 HDI 110 valves do give trouble
 

·
Registered
Joined
·
95 Posts
Discussion Starter #9 (Edited)
Hi again I've attached a image of the reading I got coming off the vaccum pump , is this ok or have I got duff vaccum pump also on idle the 2 egr vacuum solenoid was both 5% on idle through Peugeot planet ? Are these ok but when revs took up they was all over place aswell, I found that the 2 solenoid closest to air box side had barely nothing on tick over when holding thumb over the ends
 

Attachments

·
Registered
Joined
·
213 Posts
That's the same reading I got last weekend, -750. Had to change main vac feed to solenoids due to leak on T piece, then found one solenoid was passing, but also both where not working electrically. New ones coming today to be fitted Fri/Sat.
 

·
Registered
Joined
·
14,625 Posts
Planet only sees ELECTRICAL problems specifically to do with the various computers in the car

It wont for example tell you your starter is broken as it is not connected directly to the network.

vacuum is mechanical and anything mechanical is not tested by planet some things can be forced to work by planet to test the function of the part electronic EGR for example but it cannot see the vac only the solenoid
 

·
Registered
Joined
·
599 Posts
Planet only sees ELECTRICAL problems specifically to do with the various computers in the car

It wont for example tell you your starter is broken as it is not connected directly to the network.

vacuum is mechanical and anything mechanical is not tested by planet some things can be forced to work by planet to test the function of the part electronic EGR for example but it cannot see the vac only the solenoid
PP2000 sees, reports and tests everything connected to the network.

There there are several sensors related to air pressure and flow which PP2000 can read,i thought there could be one related to air vacuum, since several components of the car rely on vacuum to work properly.

Vacuum is not mechanical, the only thing mechanical is the pump itself, the rest is just a difference in pressure. Heck, even my 1992 old toyota had a simple vac meter to measure hypothetical economy. Just a pair of lights on the dash... :D
 

·
Registered
Joined
·
95 Posts
Discussion Starter #14
I have 4 of them electro valves , 2 of which I believe is to egr valve ? And also bottom one nearest to sump is boost pressure valve ? Not sure on other 1 but am I right in saying the 2 closest to air box are the egr electro valve ? Can any one help with this
 

·
Registered
Joined
·
14,625 Posts
Vacuum is not electrical either hence it cannot be measured by planet

vacuum IS mechanical as in a diesel it is generated by a mechanical device no mechanical pump no vacuum in pipes in a petrol it is generated by the pistons sucking the air in mechanically

The air pressure planet CAN measure is internal pressures IE the vacuum created by the engine mechanically sucking in air or the mechanical affect of the turbo compressing the air both are mechanical in origin
 

·
Registered
Joined
·
95 Posts
Discussion Starter #17
Do you know which is which chap , I know the very bottom is apparently turbo then just above that 1 u got another 1 and then 2 very close together near airbox also what's dozer valve ?
 

·
Registered
Joined
·
95 Posts
Discussion Starter #19 (Edited)
Hi can anyone tell me the purpose or what the black box is attached to front of gearbox with 2 vaccum pipes going into it please and then branches out to egr electro solenoid as after checking today the vaccum is very good coming from pump to this box but coming out doesn't suck my finger the slightest if I'm honest
 

·
Registered
Joined
·
95 Posts
Discussion Starter #20
Success 😀 took the 2 vacum pipes of the black box in front of gearbox and joint together with a l piece and straight away engine management and anti pollution light straight off 😀 so if I'm right the black vacuum box must of had leak ? Although a lot of power is back it still seems to dip down at points like a restricor there but already changed boost pressure solenoid?
 
1 - 20 of 53 Posts
Top