Peugeot Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1 (Edited)
Hi everyone.

About 6 months ago I bought a 2006 Peugeot 307 SW SE 1.6 HDI and I have only just noticed I have no EML.

If it had been another Vectra, the first thing I would have done was to turn on the ignition and check the EML came on and went off when I started the car. The first Vectra I bought cost over £6,000 and was the first car I had with an EML, so I did not know there should be one let alone it should come on and go off, which it did not. £6,000, today I am lucky if I can afford a £600 car.

Unfortunately, the 307’s daytime running lights were on even though it was a bright sunny afternoon and I think that might have distracted me from the EML.

The other day I looked long and hard at the display, even with a torch, I could see all the other symbols but I could not see the EML. I was beginning to think my car did not have one. Then one evening I pulled in to a car park and I do not know if it was the angle of the car, the sunlight or both but I could just make out the EML symbol. I took the instrument cluster out so I could read the part number and then bought a second hand one from ebay.

It arrived today and I have fitted it, so I now have a working EML. However, the original had 131200 miles on it but the S/H one has 144593 miles. About 14000 difference not that it matters that much as I will be the last owner of the car. When the cost of repairs to the car +£200 comes to more then the car is worth it will be scrapped.

Anyhow, I am a bit of a perfectionist so I would like have the correct mileage displayed.

Can the mileage be changed and if so how?
 

·
Moderator
Joined
·
5,983 Posts
Its not an easy job you need specific software and tool. The mileage is stored in the Clocks and BSI and always defaults to highest value.

It would have been easier to zero the secondhand clocks and then fitted it as it would have loaded the correct mileage.

Now you need the BSI and Clocks reprogramming (are you sure its not defaulted to KM)
 

·
Moderator
Joined
·
5,983 Posts
I was not doing the maths it was just a possible cause as did not know 100% mileage on replacement clocks

Sent from my SM-T830 using Tapatalk
 
1 - 5 of 5 Posts
Top