Peugeot Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter #1
Hi

I have a Peugeot 407 SW 2.0l (136) (07 plate) and the RT3 unit tries to boot up but then shuts down and it keeps cycling that way. Peugeot logo comes up but goes off after it shuts off so it does not show anything. Also my dash mileage shows Km instead of Miles now. I need help as I have no control of climate (it works but can't see the temp or where it's blowing). Obviously no radio either. Any help would be appreciated, thanks
 

·
Moderator
Joined
·
6,095 Posts
Sounds like corrupted soft/firmware, you could try using upgrade disc to reload the software.

Other than that I am sure on the RT3 there is the equivalent of a factory reset button or shorting pins within the unit which causes it to wipe all temp data and reset to default settings. I just can't find the info in my notes how to do it,
 

·
Registered
Joined
·
23 Posts
Discussion Starter #3
Hi Thanks for the reply and I tried resetting it and it still won't do anything so I have come to the conclusion it needs replacement or repairing. The repair route can very expensive so I will be looking at breakers yards. Can anyone point me where I am more likely have success in finding one. I live in Cardiff and have tried locally but no such luck.
 

·
Moderator
Joined
·
5,044 Posts
I think someone was selling one of these on my facebook page
 

·
Moderator
Joined
·
5,044 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter #10
Hi Trem1 I have contacted the person selling it and unfortunately it's the wrong type. I am grateful for your help.

I have managed to test the hard drive inside the unit and it is not working and not reading the information and I have put another hard drive in and now it boots up and stays on however because it is a new drive the message comes up "Please insert upgrade disc". Can anyone help me with this so I can somehow get another step closer to getting my unit up and running. Thanks
 

·
Moderator
Joined
·
5,044 Posts
Ask on the fb page as well someone will be able to help

Sent from my SM-A320FL using Tapatalk
 
1 - 11 of 11 Posts
Top