Peugeot Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi
Just need to pick brains before I tear my hair out! Being a useless girlie with engines I've been having a nightmare with my Partner 1.9d van. Recently had major work done..cam belt, alternator, water pump, exhaust and new tyres and now there is a god awful noise coming when I accelarate. Nothing heard when engine not revving. Friend had a quick look and he saw the air pump box was very loose so he tied a bungie round that and it was better but still very loud. He's away this weekend so without having to resort again to a mechanic who I don't entirely trust, could this noise be the air filter box that needs replacing or are we looking at yet another expensive gargage visit?

Any clues? I know it's a very vague discription....
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Its connected by the main bit (sorry I told you I was useless with engines) would it make that sort of noise if it's faulty? It's sounds like the exhaust is shot but having just had that repaired it can't be that. :confused:

It's been suggested the cam belt is loose, is that something that could happen after it being replaced 2 months ago and would that cause a noise that only happens when accelarating?
 

·
Registered
Joined
·
424 Posts
I'd bet money it's an air filter / intake pipe problem from what you're describing

if you've recently had all that work done it may be that they just haven't reconnected the air intake pipe to the filter housing properly or it's since come loose leaving a small gap

just check the air intake pipe, where it connects to the filter housing it's usually secured by a jubilee clip... just make sure it's secured tightly
 
1 - 4 of 4 Posts
Top