Peugeot Forums banner
1 - 8 of 8 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi .. I’ve got a new 19 plate Rifter and the engine management light and ad blue flashing light came on .. plus countdown to “no start “ .. taken it to main dealer and they can’t work out what problem is .. fitted new ad blue pump and nox sensor .. still keeps on happening . It’s still under warranty so guess they will keep on trying different fixes ? Just wondered g if anyone else has had this problem and/or has any ideas what’s going on with other it ?
 

·
Registered
Joined
·
1 Posts
Hi .. I’ve got a new 19 plate Rifter and the engine management light and ad blue flashing light came on .. plus countdown to “no start “ .. taken it to main dealer and they can’t work out what problem is .. fitted new ad blue pump and nox sensor .. still keeps on happening . It’s still under warranty so guess they will keep on trying different fixes ? Just wondered g if anyone else has had this problem and/or has any ideas what’s going on with other it ?
I am having same issues. I got a new adblue pump and box sensor fitted yesterday adblue and engine management light came on
 

·
Registered
Joined
·
1 Posts
I am having same issues. I got a new adblue pump and box sensor fitted yesterday adblue and engine management light came on
Just wanted to add my own experience. Rifter only 1 and a half years old, about 3 months ago the emissions warning light/adblue light came on and gave me 700 miles till no start, eventually managed to get a slot in the dealers, they took it in and explained they had "updated" the software and couldn't find anything else wrong. 2 weeks later, came on again but this time only gave us 50 miles to no start, as we were away from home we had to call RAC, they reset everything but the very next day happened again, 50 miles to no start, called RAC again, reset everything and we got home no problems. Two weeks later, same thing, took it back to the dealers and they explained they replaced the adblue tank (no idea why). Got car back on a Thursday and on the Friday light came back on but this time it gave us no countdown, simply "starting impossible". I had no choice but to turn off the engine where I was and tried restarting and it did restart!. Went an did what I had to do, came back to the car 30 minutes later, nothing, wouldn't start. Called RAC again, reset everything and now it's back in the dealers and we have a crappy replacement MG ZS which is absolutely awful (but I digress). Simply a shocking experience from Peugeot and if we get the car back from the dealers and this happens again we're simply rejecting the car as it is a Motability vehicle and it's unpredictability is of no use to my wife whatsoever, the first few times this happened she was in the car, the last time she wasn't thankfully, otherwise it would have been a major issue for us to sit and wait for the RAC patrol, who to their credit, have been fabulous each and every time.

Would love to know if anyone else has had similar experiences and if they got the resolution eventually :)
Marko
 

·
Registered
Joined
·
1 Posts
Just an addition to the thread. Purchased a 19 plate rifter from main dealer ex mobility car. Car had been fine driving and after about 1000 miles the AdBlue light came on the way back from a journey. Took to the dealership the next day as the car was meant to be fully serviced before they gave it to us. 20000km is the stated refil time for the AdBlue tanks and as such from new this was probably the first time anything had been done on it. Main dealers topped up the AdBlue and i asked how much they had got in and the reply was 18lts (good for a 17lt tank) That was 3 weeks ago and we have been down with covid since then with no journeys and the AdBlue light has come on again. Garage cant see us til Tuesday so bought some AdBlue and went to top up only managed to get about 1ltr in before it came back out.
 

·
Registered
Joined
·
2 Posts
Hi Marco, I have just seen you have had problems with your rifter and the dreaded add blue! We are currently having this issue, this is the 3rd time now, both other times it went back to peugeot and they did a system update and it reset it, they promised it wouldnt happen again but low and behold that dreaded message appeared! I've topped it up and the message is still showing. I've had enough of this car now. What did you do in the end? Did they replace the car?
 

·
Registered
Joined
·
2 Posts
Just wanted to add my own experience. Rifter only 1 and a half years old, about 3 months ago the emissions warning light/adblue light came on and gave me 700 miles till no start, eventually managed to get a slot in the dealers, they took it in and explained they had "updated" the software and couldn't find anything else wrong. 2 weeks later, came on again but this time only gave us 50 miles to no start, as we were away from home we had to call RAC, they reset everything but the very next day happened again, 50 miles to no start, called RAC again, reset everything and we got home no problems. Two weeks later, same thing, took it back to the dealers and they explained they replaced the adblue tank (no idea why). Got car back on a Thursday and on the Friday light came back on but this time it gave us no countdown, simply "starting impossible". I had no choice but to turn off the engine where I was and tried restarting and it did restart!. Went an did what I had to do, came back to the car 30 minutes later, nothing, wouldn't start. Called RAC again, reset everything and now it's back in the dealers and we have a crappy replacement MG ZS which is absolutely awful (but I digress). Simply a shocking experience from Peugeot and if we get the car back from the dealers and this happens again we're simply rejecting the car as it is a Motability vehicle and it's unpredictability is of no use to my wife whatsoever, the first few times this happened she was in the car, the last time she wasn't thankfully, otherwise it would have been a major issue for us to sit and wait for the RAC patrol, who to their credit, have been fabulous each and every time.

Would love to know if anyone else has had similar experiences and if they got the resolution eventually :)
Marko
Hi Marco, I have just seen you have had problems with your rifter and the dreaded add blue! We are currently having this issue, this is the 3rd time now, both other times it went back to peugeot and they did a system update and it reset it, they promised it wouldnt happen again but low and behold that dreaded message appeared! I've topped it up and the message is still showing. I've had enough of this car now. What did you do in the end? Did they replace the car?
 

·
Registered
Joined
·
1 Posts
Hi guys, I have about the same problem with the adblue sensor ( the countdown won't reset after top up). I've bought my rifter in October 2021 brand new and about every 3000 miles I had to to go into the dealership because the countdown won't reset. I've been about 6 times already and something happened to the adblue tank and they are somehow forced to replace the tank, but because it's a wav needs to order the tank from Peugeot to send it to Scotland to be modified ....all together I've been told 6 weeks.....very frustrating
 
1 - 8 of 8 Posts
Top