Peugeot Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
Hi everyone, I have a couple of electrical problems with my 308 that I hope someone may be able to shed some light on and offer some advice. I'm not that great with the electrical side of car mechanics so please bare with me.

My reverse light either flickers on and off or does not come on at all, have tested bulb and tried new bulb which both work. The Speedo is working which I read someone on here mention it uses the same fuse? Guessing it must be something to do with wiring/ switches?

My other problem is my rear washer activates randomly wasting windscreen wash for no reason, again guessing an electrical fault? Sometimes it doesn't come on at all during driving, others it will activate several times in succession without being touched.

Any help would be greatly appreciated, hoping these aren't complicated issues as would like to fix these myself. One other note I replaced my battery a couple months ago so don't think it would be related to that.
 

·
Registered
Joined
·
4 Posts
Sounds like a dodgy reverse light switch. This is screwed into the side of the gearbox and is activated when putting the vehicle in reverse. It would explain both your problems. Usually a quickish job but I don't know the position of the switch on the 308
 

·
Registered
Joined
·
13 Posts
Discussion Starter #3
Hi Pilot, thanks for the reply!

I managed to change the reverse light switch today after locating it in the front of the gearbox below the battery, my reverse light is now working again! :D with regards to the dodgy rear washer, this wouldn't be linked to the reverse light switch surely? I've read that it could be the Comm 2000 unit behind the steering wheel that is causes faults such as this? Sounds a bit technical for me if so!
 

·
Registered
Joined
·
4 Posts
There is a connection. In the vehicle settings, accessed through the touch screen it is possible to activate the rear wiper automatically when reverse is selected and the front wipers are in use. If the new switch has not cured the problem and it is the comms unit deactivating this feature may stop them working erratically.
 

·
Registered
Joined
·
4 Posts
Sorry just noticed that its the rear wash that your having trouble with so much of above is irrelevant.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #6
Thanks for your help Pilot, much appreciated! Ok so to clarify, this is most likely a comms unit fault? Anything else it could be that causes the rear washer to act on its own? Just want to be 100% confident before I buy new units etc.
 

·
Registered
Joined
·
2,555 Posts
Just to be clear about this, you see water from the washer on the rear window? Or is it just the wiper moving?
 

·
Registered
Joined
·
13 Posts
Discussion Starter #8
Hi Brian, It's the rear washer shooting screen wash all down the rear screen followed by the wiper to clean it up with no input whatsoever from me!
 
1 - 8 of 8 Posts
Top