Peugeot Forums banner

1 - 15 of 15 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1 (Edited)
My reverse camera has stopped working on my 2017 3008 GTline, the mirrors still drop but I get no reverse image apart from the black screen with a orange warning triangle as shown in my picture, does anyone know why this has happened?
90710
 

·
Registered
Joined
·
18 Posts
Discussion Starter #6
I had the same problem with this around 18 months ago, I took it back to
the the Peugeot garage I bought it from and the garage and Peugeot at that time had not heard of this problem before, they started by replacing the camera which did not resolve it, they then ended up replacing the wiring loom from the LCD screen to the camera and at one stage they even had to take out the back window to access the wiring and it worked. 3 weeks later it stopped working again, I took it back and when I got into there carpark it decided to work again, they couldn't test for a fault if it was working correctly.
It has been fine for 18 months and now the same problem has arisen. I have it booked back in for this Wednesday, my warranty ran out at the beginning of October but my Peugeot dealer said Peugeot would honour the repair.
I will keep you updated.
 

·
Registered
Joined
·
26 Posts
I had the same problem with this around 18 months ago, I took it back to
the the Peugeot garage I bought it from and the garage and Peugeot at that time had not heard of this problem before, they started by replacing the camera which did not resolve it, they then ended up replacing the wiring loom from the LCD screen to the camera and at one stage they even had to take out the back window to access the wiring and it worked. 3 weeks later it stopped working again, I took it back and when I got into there carpark it decided to work again, they couldn't test for a fault if it was working correctly.
It has been fine for 18 months and now the same problem has arisen. I have it booked back in for this Wednesday, my warranty ran out at the beginning of October but my Peugeot dealer said Peugeot would honour the repair.
I will keep you updated.
Thanks for the reply,
Mine went in to the dealers in may and they changed the boot latch which worked up and till last week now I'm back to getting the black screen again! But it doesn't do it all the time
 

·
Registered
Joined
·
18 Posts
Discussion Starter #8
Mine has gone back in today, the camera worked when I got there but they said they would still have a look, it seems to play up after we have had a lot of rain as it worked fine all through summer, so water may be getting in somewhere, I will keep you updated.
 

·
Registered
Joined
·
18 Posts
Discussion Starter #9
Mine has gone back in today, the camera worked when I got there but they said they would still have a look, it seems to play up after we have had a lot of rain as it worked fine all through summer, so water may be getting in somewhere, I will keep you updated.
I have picked my car up from the Peugeot dealer and they said the camera and the monitor were losing the connection with each other, they said there was an update available so they done that and said that this update should cure the fault, if the fault was to return they said bring it back. Time will tell!
 

·
Registered
Joined
·
26 Posts
I have picked my car up from the Peugeot dealer and they said the camera and the monitor were losing the connection with each other, they said there was an update available so they done that and said that this update should cure the fault, if the fault was to return they said bring it back. Time will tell!
Thanks for the update much appreciated.
I'll give the dealers a ring and see if I can get mine updated.
 

·
Registered
Joined
·
2 Posts
I seem to be having the same issue too. The camera will work usually in the first instance, so when I'm reversing from my driveway. But after about 5-10 minutes, if I go to reverse again I just get that Warning sign. Quite frustrating, we've not long bought the car (17 plate) from a local dealership (not Peugeot) and this is the only thing that is bugging me about the car, I love it otherwise.

I updated the cars software at the weekend thinking that would solve the issue but it hasn't :( so I'm guessing it's going to be a costly job by asking Peugeot to look into it/fix it

I have picked my car up from the Peugeot dealer and they said the camera and the monitor were losing the connection with each other, they said there was an update available so they done that and said that this update should cure the fault, if the fault was to return they said bring it back. Time will tell!
Thanks for the update much appreciated.
I'll give the dealers a ring and see if I can get mine updated.
Have you guys had much luck in the meantime getting this resolved?
 

·
Registered
Joined
·
18 Posts
Discussion Starter #12
I seem to be having the same issue too. The camera will work usually in the first instance, so when I'm reversing from my driveway. But after about 5-10 minutes, if I go to reverse again I just get that Warning sign. Quite frustrating, we've not long bought the car (17 plate) from a local dealership (not Peugeot) and this is the only thing that is bugging me about the car, I love it otherwise.

I updated the cars software at the weekend thinking that would solve the issue but it hasn't :( so I'm guessing it's going to be a costly job by asking Peugeot to look into it/fix it




Have you guys had much luck in the meantime getting this resolved?
The update seemed have cured the problem but the next day it was at fault again, I think it has something to do with the weather, if we have a day of rain/mist it stops working, after a full dry day it's back to working again.
When I book the car in to be fixed the camera is not working, on the day I take it to the garage most of the time the bloody thing works OK, obviously they can't test for a fault if it's working.
This was reported when the fault developed 1st time around 18 months ago. At that time they tested for any leaks coming in and nothing was found. During the summer it worked OK with no problem.
Even though the warranty ran out in October the Peugeot garage said they would still fix it under warranty which is very good of them. Over all my car must have been to the dealer over 10 times now and I am going to give up trying to get this fixed, I can't keep taking time off from work go to and from the garage.
If anyone has this this problem and get it fixed in the future can they please let me know, Thanks in advance.
 

·
Registered
Joined
·
598 Posts
Okey, so the camera is not dead. I believe you have a wiring problem. If your car is automatic and next time it happens, you can leave it in reverse and activate hand brake, then go out and try to hit around the camera with your hand to see if it'll start working. If not automatic, someone else can do the hitting. I had the same issue, but I personally installed the camera in the car, the same one you have, and my wiring was poor. After I re-did it, no more issue.
 

·
Registered
Joined
·
18 Posts
Discussion Starter #14 (Edited)
I have a manual car, so I tried what you said and after tapping on the camera this appeared on the screen, as I walked around the back of the car the orange marker follows your movement left, rear and right and so on, it is not showing the live video footage so I believe there is a fault with the camera. 1st picture before tapping on the camera. I will report this to the garage.
 

Attachments

·
Registered
Joined
·
2 Posts
I have a manual car, so I tried what you said and after tapping on the camera this appeared on the screen, as I walked around the back of the car the orange marker follows your movement left, rear and right and so on, it is not showing the live video footage so I believe there is a fault with the camera. 1st picture before tapping on the camera. I will report this to the garage.
It’s the same in mine too, the sensors seem fine just the camera only works when it wants to
 
1 - 15 of 15 Posts
Top