Peugeot Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
I brought my car about a month ago and the rear wiper does not work. When turning the rear wiper on you can hear a noise (like the motor is working in it) but the wiper does not move. I lifted the wiper up with my hand to see if it would move and it does when its turned on. I dont know if the wiper is similar to how a cog works and its not sitting on it properly or what. Really need help with this please. Thanks
 

·
Registered
Joined
·
248 Posts
If you lift up the plastic cover, can you see the centre spindle turn when the motor is on - or is the wiper lose when you move it.

It could be that the wiper arm mount where it bolts to the wiper motor is cracked. This will mean that there is not a tight connection to the motor spindle and it wont turn.

If that's the case, you can buy a new arm and simply replace it.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3
I have lifted up the cover and yes when the motor is on all that moves is the centre spindle. Ive now took the wiper off with a struggle and it looks corroded. Not sure if I would need a new arm for it and a new centre spindle or what to be honest.
 
P

·
Guest
Joined
·
0 Posts
I have lifted up the cover and yes when the motor is on all that moves is the centre spindle. Ive now took the wiper off with a struggle and it looks corroded. Not sure if I would need a new arm for it and a new centre spindle or what to be honest.
Try a new arm, they are cheap enough. I had to have all mine off last week. The snow had bend the arm, thanksfully managed to sort. I think the moving part is part of the motor isn't it? Looks that way in mine at least (SW version)

And yeah, they get dirty so quick its unreal.
 
1 - 5 of 5 Posts
Top