Peugeot Forums banner

1 - 16 of 16 Posts

·
Registered
Joined
·
206 Posts
Discussion Starter #1
after seeing if my stalk was eligable for the displays,off popped the end of my stalk along with a ribbon ,missus wasnt happy after i told her :(

i take it it cant be placed back inside the stalk? the end looks like its just a bit of sticky pad.
 

·
Registered
Joined
·
4,778 Posts
after seeing if my stalk was eligable for the displays,off popped the end of my stalk along with a ribbon ,missus wasnt happy after i told her :(

i take it it cant be placed back inside the stalk? the end looks like its just a bit of sticky pad.
is it a delphi unit or a dav unit?
 
D

·
Guest
Joined
·
0 Posts
You'll have to remove the whole unit and strip it. The stalk can be refitted if its not broken.
 

·
Registered
Joined
·
206 Posts
Discussion Starter #5
i think i have broken it. the actual ribon itself flu out when i popped the end off lol
the end of the ribbon is like a pc ribon where they click down on a board etc was wondering if anyone knows if its same princible.
 

·
Registered
Joined
·
5,904 Posts
i think i have broken it. the actual ribon itself flu out when i popped the end off lol
the end of the ribbon is like a pc ribon where they click down on a board etc was wondering if anyone knows if its same princible.
I've never had one apart so don't know how the ribbon attaches but, if all the cable ends have tinned wire and are all the same length then it could well be that the connecter is the type that holds the ribbon in by trapping it rather than being soldered on so the ribbon could be refitted. You would have to make sure it went in the correct way round though.
 

·
Registered
Joined
·
4,778 Posts
i think i have broken it. the actual ribon itself flu out when i popped the end off lol
the end of the ribbon is like a pc ribon where they click down on a board etc was wondering if anyone knows if its same princible.
the ribbon is only wedged in if you pull the cap up on the connector and push the ribbon back in then push the cap back down if you get stuck then there is a guy on ebay who repairs comms units and did a great job with mine
 

·
Registered
Joined
·
206 Posts
Discussion Starter #9
the ribbon is only wedged in if you pull the cap up on the connector and push the ribbon back in then push the cap back down if you get stuck then there is a guy on ebay who repairs comms units and did a great job with mine
ive come across the repairs on ebay,ill have a look into it,thanks

better to source a new one i tried doing mine got the ribbon back in but broke the air bag wires so need a new one anyway lol :thumb:
id prob do same lol There's 2 307's around same year in my local breaker so ill see what they want for a new stalk.

so, ya can repair then but its not a d.i.y job :D

Thanks for help :thumb:
 

·
Registered
Joined
·
4,778 Posts
U can if U know what ur doing but better to have someone do it getting one new next week 155 delivered and check the numbers first coz there all different
i does not have to be the same numbers but here is a list of things to check for

auto lights or wipers
if your car has auto light or wipers then unless you want to loose this function you need a unit with the buttons on the end of the stalk

front fogs
this does not matter as a unit with no front fogs will work the same it just wont have the marking to say it has front fogs but will still operate them

esp
if your car has esp then you need a unit with the steering angle sensor in it and you also need to have it programed to the car

black connector
the 307 has a black connector but the 206, 406 does not, a 307 unit will work on a 206, 406 but a 206, 406 unit will not work on a 307

trip button
if your car has a trip button then unless you want to loose this function you need a unit with a trip button

radio stalk
this does not matter as this just unclips from your old unit
 

·
Registered
Joined
·
235 Posts
hi

from what am led to believe from people on here Peugeot, Peugeot breakers and factors they have to be the same units and if not can cause things not to work and some will go together if u know what numbers too look for and to be fair 155 is not bad for a new unit with 12 months warranty and the units on eBay were 80 plus and u never know if they work u take a chance so just getting a new unit with the right numbers so they will deffo be ok :thumb:
 

·
Registered
Joined
·
4,778 Posts
from what am led to believe from people on here Peugeot, Peugeot breakers and factors they have to be the same units and if not can cause things not to work and some will go together if u know what numbers too look for and to be fair 155 is not bad for a new unit with 12 months warranty and the units on eBay were 80 plus and u never know if they work u take a chance so just getting a new unit with the right numbers so they will deffo be ok :thumb:
the guy who repaired mine on ebay sells units for about £60 with 6 months warranty
 

·
Registered
Joined
·
206 Posts
Discussion Starter #15
New stalk needed maybe

So after fixing the horn today,whilst at it i took the wheel off to see how you get the stalk control off. didnt know how to remove the airbag ring and plus there were about 5 plugs underneath so decided to put it all back together.

After looking at the guys pic on ebay,he may not be able to fix my stalk as it is the same as the pic bottom right. Blue + Green and a Grey connector with white wires attached,seems he cant fix those :(

If he can take apart a stalk and a control board then i maybe in for a win,ive emailed him again but we'll see.

Mike
 

·
Registered
Joined
·
206 Posts
Discussion Starter #16
All fixed :)

me and a mate fixed my rear wiper twist button today :)

easy enough to get the stalk controls out (after we realised the airbag ring is all one unit) 1 10m bolt holding it all on. we simply guided the ribbon back through the stalk (with help of a long flat head screwdriver and a pair of pliers) and clipped it back in the boards plastic socket (pull up and clip down).Put it back together bar the s/wheel and it didnt work..had the ribbon in the wrong way,so now it all works again

wasnt as easy as that lol was tricky attaching the stalk back in place etc etc

Also,after trying to get the end back off,the actual button came off so then we was left with a board....
[URL=http://s329.photobucket.com/user/mikedenney/media/Image000-1.jpg.html][/URL]
It seems when i twisted the end off,i twisted it too much and the whole thing came out. So now i m on look out for a trip button :)
 
1 - 16 of 16 Posts
Top