Peugeot Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
38 Posts
Discussion Starter #1
Hi, Having just bought 2nd Pug 407 SW, got slight problem with back screen, it wont open when push button at bottom of wiper arm but makes the clicking sound, it does open using key, also just noticed that rear screen demister isnt working either, could this be a broken wire? Looked at other post regards that but not sure if wires all run up there regards the screen release
 

·
Registered
Joined
·
533 Posts
A broken wire is possible. Here's the Peugeot Toolbox exploded diagram. Unfortunately it doesn't come any bigger than this:

407RGlass.jpg

A: TAILGATE GLASS

13: TAILGATE WINDOW HARNESS

THE GLASS (A) AND HARNESS (13) ARE ONE UNIT

45: OPENING WINDOW STOP -- SINCE RPO 10955

78: RIVET - 1T 5 LONG 14 - HEATED REAR SCREEN HARNESS CONNECTOR FIXING
 

·
Registered
Joined
·
38 Posts
Discussion Starter #3
Tanks for that, at least it gets me a start, was looking at trying to get wiper mecanism off but knowing me i would break it
 

·
Registered
Joined
·
533 Posts
As you did not say that the wiper was not working, have you checked the fuses and the current to the heated window and lock release?

If I recall correctly, there is a thread on repairing a broken wire to the tailgate. (Though I can't find it now.
 

·
Registered
Joined
·
38 Posts
Discussion Starter #6
As you did not say that the wiper was not working, have you checked the fuses and the current to the heated window and lock release?

If I recall correctly, there is a thread on repairing a broken wire to the tailgate. (Though I can't find it now.
I found the thread about the broken wires , not sure how to check current to screen, prob easier to check wires,
Thanks
 
1 - 6 of 6 Posts
Top