Peugeot Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
Hi does nyone know if peugeot 307CC rear hub nuts are left hand threads or right hand
Also ABS problem had it check by one of the forum guys with pp he found that my rear passenger side senor was corroded ( rust) got it all cleaned up and working but now its happened again so done a reclean of eveything but before abs light came on at 30 mph now its off until 40 mph
But if i put ignition on just before motorway and increase speed quick it stays off till i leave motorway and drive slower
Main reason for removing hubs to to check if any are damaged or dirty
Did have a car manual but cannot find it now we have moved
Thanks in advance for any help this is driving me crazy
I also have a whriling noise come from the front of car from abs system ?
When applying my foot brake
Thanks driverhgv
 

·
Registered
Joined
·
2,179 Posts
The noise will be the ABS working thinking there is a skid so the signal from that rear wheel is probably dodgy. So if it has been cleared down to sound metal and it is sitting square the problem is either the sensor or the sender.
 

·
Registered
Joined
·
15,377 Posts
Hub nuts are normal thread but pretty tight you may need a 3/4 drive socket to loosen them.

ABS fault could be anything its unlikely to be the same thing again it could just as easily be the front.

Sounds like a coherence fault with a sensor.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #4
Hi madbadandold also reliable405 thank you both for quick replies
It was about two years ago when i first cleaned the backplates of the sensor
And it was pretty rusted again spent around 1 1/2 cleaning everything back to clean metal
Do you think it would be best to first replace the sensor ?
I noticed that the metal clip on the sensor that holds it to the backplate is pretty corroded and it seems loose too
Was wondering if its not holding sensor in right place to the ring ie 2 mm
Then could that be causing the problem ?
Or if the ring that returns info for sensor is broke or dirty
Would either of you know the torque for replace hubnuts are ?
Many thanks again
 
1 - 5 of 5 Posts
Top