Peugeot Forums banner

1 - 17 of 17 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Peugeot 307 1.4 8v with A/C

Hi everyone, I have a problem with my plug, the engine is running very rough, with loss of power, Anti Pollution Fault warning on display. Plugged in a hand held device to read the Error codes, which came back, P0300 random misfire
Parts replaced so far:
1. throttle body
2. Spark Plugs
3. Coil pack
4. Idle control valve
5. Temperature Sensor
6. Crankshaft Sensor
7. Throttle Valve positioned motor
8. Lambda sensor (Before CAT)
9. All the Injectors
After replacing all these parts i am at a loss to what is cause this random misfire

Thanks in Advance

caseysw
 

·
Registered
Joined
·
9 Posts
Discussion Starter #6
Update, After check the valve clearances today i changed the down stream lambda sensor, after reading some other posts, and the error codes have changed to P0300 and P0110.

P0300 Random Misfire
P0110 Intake Air Temperature Circuit Malfunction

Does anyone know where the Intake Air Temperature Circuit is on a petrol 1.4 8v
and would changing this fix the random misfire???
 
D

·
Guest
Joined
·
0 Posts
Nope shouldn't make a difference. What plugs have you in the car?

Sent from my GT-S5690
 
D

·
Guest
Joined
·
0 Posts
What did you set valve clearances to? .2 and .4?

Sent from my GT-S5690
 
D

·
Guest
Joined
·
0 Posts
Have you definitely the correct coil fitted? What yr is the car again?

Sent from my GT-S5690
 
D

·
Guest
Joined
·
0 Posts
Is the timing correct? Pin it up, it'll take five min to check.

Sent from my GT-S5690
 
1 - 17 of 17 Posts
Top