Peugeot Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi all, looking to see if anyone’s had any similar (random white blue exhaust smoke) with this type of engine.
The engine runs fine apart from every once or twice a week weather the engine is warm or hot, the cooling fan will come on then the engine will pour out white blue smoke from the exhaust when pulling away?
I’ll pull over turn engine off for five minute start up and no smoking until next time.
I’ve done the usual changed oil and all filters I’ve got no warning lights or codes on diabox.
I’ve had a a look on the bipper forum and someone had the exact same problem but with no reply’s, so I put this out here just in case anyone has had similar problem with the hdi engine?
Any thoughts or suggestions on where to go with this would appreciate.
Thanks
 

·
Registered
Joined
·
3 Posts
Discussion Starter #2
Follow up....

Good evening all, still no response to my Smoking issue as yet... Im going to keep it updated as best i can hoping that someone can touch on this problem?

Anyways im starting to now believe my car is doing (random) dpf regeneration but Im not getting any flags from dash?
Ive had regeneration's on this car before where the filter would light up with display message....

On the way home today pulling on to carriageway the white/grey smoke appeared from tailpipe and cooling fan on, so I booted it with plumes of white grey smoke up to about 2500 rpm then it clears then it stops after about 10 minuets no smoke cooling fan off?

So ive read when doing a regeneration more fuel is injected possibly from only 1 injector so maybe that's an area to look at?
Im thinking the cooling would come on automatically as higher engine temps for regeneration is that correct?

Ill run car connected to diagbox in the hope i can catch it at it and see what the difference in parameters are though id need some advice on these readings please.

Thanks for any thoughts
 

·
Registered
Joined
·
1 Posts
Follow up....

Good evening all, still no response to my Smoking issue as yet... Im going to keep it updated as best i can hoping that someone can touch on this problem?

Anyways im starting to now believe my car is doing (random) dpf regeneration but Im not getting any flags from dash?
Ive had regeneration's on this car before where the filter would light up with display message....

On the way home today pulling on to carriageway the white/grey smoke appeared from tailpipe and cooling fan on, so I booted it with plumes of white grey smoke up to about 2500 rpm then it clears then it stops after about 10 minuets no smoke cooling fan off?

So ive read when doing a regeneration more fuel is injected possibly from only 1 injector so maybe that's an area to look at?
Im thinking the cooling would come on automatically as higher engine temps for regeneration is that correct?

Ill run car connected to diagbox in the hope i can catch it at it and see what the difference in parameters are though id need some advice on these readings please.

Thanks for any thoughts
hi i have got the same problem no one seems to know the answer
 

·
Registered
Joined
·
284 Posts
First of can you post your engine code, so we know the engine type, also you will need to hook it back up to planet and look at live data not all running problems throw codes, you were right it does sound like an injector fault one that is over fueling no longer misting and the excess diesel is hitting the hot exhaust and burning off, I would be doing a leak off test for sure and checking live data in the injection system whilst the cars running on planet report back your findings and someone hear will be able to help there is couple of folk on hear with a wealth of knowledge regarding the HDI Engine.
 
1 - 4 of 4 Posts
Top