Peugeot Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
It further drains my battery.
Running at full speed.

I have cleaned the relay on the radiator compartment with silicon spray but it doesn't last more than 6 hours and it happen again.

When placing the key on ignition, the fan will turn off.

Any clue what's wrong with my peugeot 407?

Thank you in advance
 

·
Registered
Joined
·
36 Posts
I'm not sure if all Peugeot models does this, but sometimes the fan will keep running for few minutes even after ignition off, but I don't think the fan runs at high speed.

When engine is on does the fan always run at high speed, or it toggles between low and high speed?
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
it only turning when i on the aircond and when temperature reached optimum temperature.

but when ignition is off, suddenly within 6 hours, the fan run on its own at high speed, draining my battery flat.

right now i have changed the relay located underneath the passenger glove box(left for right hand side model) and the fan no longer spins like crazy
 

·
Moderator
Joined
·
12,372 Posts
Silicon spray?

Should be using electrical contact cleaner on any electronic components.
 

·
Registered
Joined
·
52 Posts
It further drains my battery.
Running at full speed.

I have cleaned the relay on the radiator compartment with silicon spray but it doesn't last more than 6 hours and it happen again.

When placing the key on ignition, the fan will turn off.

Any clue what's wrong with my peugeot 407?

Thank you in advance

You should change the relay, cleaning doesn't work for it. I had symptom of fan not running and I cleaned with silicone spray but nothing changed. but once got a new relay, the symptom just gone.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
You should change the relay, cleaning doesn't work for it. I had symptom of fan not running and I cleaned with silicone spray but nothing changed. but once got a new relay, the symptom just gone.
im thinking of bypassing the 12v supply to the relay and add a wire with a switch and runs it through cabin hole near the foot area. which i will have to switch off when turning of ignition, and turn on before ignition

what do u think?

because i already changed the relay and this issue still ocassionally happening. i will risk my battery.

but i do know the risk of forgetting to turn on the switch will cause the aircond not cold and engine will overheat
 

·
Registered
Joined
·
10 Posts
It further drains my battery.
Running at full speed.

I have cleaned the relay on the radiator compartment with silicon spray but it doesn't last more than 6 hours and it happen again.

When placing the key on ignition, the fan will turn off.

Any clue what's wrong with my peugeot 407?

Thank you in advance
If its diesel it could be a regeneration issue, (search this forum for fixes for that). Or it could also be for either petrol or diesel a thermostat sensor issue.

Look at your fault codes.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #8
If its diesel it could be a regeneration issue, (search this forum for fixes for that). Or it could also be for either petrol or diesel a thermostat sensor issue.

Look at your fault codes.
it is petrol model
My temporary solution now is bypassing the 12V DC supply to the radiator relay and add a manual switch that runs underneath driver compartment
this does the magic


I did this because both relays on the radiator and glove box has been changed to new one and the issue not solved
 
1 - 8 of 8 Posts
Top