Peugeot Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
1,953 Posts
Bad picture with the glare but according to the tacho that engine is not running!
Also difficult to diagnose accurately without a description of conditions etc when it happens and some history and details of the vehicle! Also only photo shown with no sign of video!
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
Bad picture with the glare but according to the tacho that engine is not running!
Also difficult to diagnose accurately without a description of conditions etc when it happens and some history and details of the vehicle! Also only photo shown with no sign of video!


The history of the machine was left in the garage
change the belt and pump i next morning came pick up car and see this erros
blinking and does not show rpm and speed fuel and radio not work
car starting perfect and drive
 

·
Registered
Joined
·
147 Posts
The history of the machine was left in the garage
change the belt and pump i next morning came pick up car and see this erros
blinking and does not show rpm and speed fuel and radio not work
car starting perfect and drive
So from that description I believe you had some work done at a garage. Take it back to them and tell them they have done something wrong. You need speedometer at the very least to be road legal.

You still haven't told us what sort of 307 it is. Petrol diesel, engine size etc. The solution may well be different for each one.

For what it's worth BSI reset would be my starting point. My guess is they didn't disconnect the battery properly.
 
1 - 8 of 8 Posts
Top