Peugeot Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hi all,
I have a 54 plate 307 hdi 2 litre.
Whenever I try to start my car from cold it struggles to start. It takes about 20-30 seconds to turn over, when it does turn over there is usually a plume of grey smoke. If the weather is too cold it wont start.
When I turn the key to the first position for the dashboard lights to come on the normal lights go out e.g glowplugs but the stop light stays on, it goes off when the engine is started.
So far I have had a new battery and a new set of glowplugs. I have also had diagnostics which has no faults. Any help/advice would be much appreciated.
 

·
Moderator
Joined
·
5,616 Posts
I would look at replacing the starter motor common fault on these starter is under spec and once it get worn/old it does not have enough power to spin the engine fast enough to get good starting
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
Thanks for your reply.
I first thought of the starter motor but it seems strong enough.
Whilst trying to turn the engine over it seems to turn perfectly with the battery draining before firing up. The problem doesn't seem to be intermittant, it only happens when the engine is cold. When the engine is warm it works perfectly everytime. I'm not a mechanic, these are just my observations.
 

·
Registered
Joined
·
691 Posts
It's the starter motor, it's underpowered and a known fault. The original starter is too low powered at 1.4kw. Look for an up rated one at say 1.7, 1.8 or 2.0 kW.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
Thanks for the reply.
As both replies say it was the starter motor I decided to change it. The new one is 1.7kw. I just tried starting from cold and i'm still having the same problem.
Any ideas?
 
G

·
Guest
Joined
·
0 Posts
Do you have an in-tank lift pump?

When you first put the ignition on, is there a short whirring sound for maybe 5 seconds?

If no sound, then you may either have a dodgy pump, or no pump at all - depending on ECU/Injection type.

Do you have a primer bulb in the engine bay, its like a big plastic bubble in the fuel line.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7
Thanks for the reply.
I dont know if I have an in tank lift pump but I know there isn't a primer bulb. I do have a whirring noise when turning on the ignition. I wait for this noise to go off before starting the engine because the glowplug sign goes off straight away.
 

·
Registered
Joined
·
4,777 Posts
Thanks for the reply.
I dont know if I have an in tank lift pump but I know there isn't a primer bulb. I do have a whirring noise when turning on the ignition. I wait for this noise to go off before starting the engine because the glowplug sign goes off straight away.
You need it on planet to check live data

Fuel pressure
Cranking speed
Cam crank sync
Ecu unlocked
 
1 - 8 of 8 Posts
Top