Peugeot Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Good Afternoon

I have put a new bulb in my passenger fron indicator but it is still not working, the old one worked intermittently

My passenger airbag is deacivated for some reason

I had a new back windscreen but they did not connect my rear window heater back up any suggestions

Thanks in advance
 

·
Registered
Joined
·
28 Posts
hi pal, ive had same airbag issue, went to diagnostics place fella said its the airbag modual located under ashtray price was 200 pounds for new part then fitting on top, yours might be different id take it to diagnostics get it checked
 

·
Registered
Joined
·
9,733 Posts
Take the indicator bulb holder out and look at the connections on the side they more than likely are burnt through , either a touch of solder , rewire to headlights or buy a new one.
 

·
Registered
Joined
·
4,506 Posts
i had a dodgy indicator bulb holder, bettyswollocks is mentioning, i picked one up from a dealership for only a few quid....they look slightly different so i think they may have improved them.
 
J

·
Guest
Joined
·
0 Posts
Before you take it to a garage for the air bag thing, does your car take much time to start up? And when is the last time you changed the battery?

I find with my car that if its a cold morning or it takes some time chewing over before it starts, that the system likes to turn things off. Usually passenger air bag.

Try turning passenger air bag key off, start car, turn off car, turn passenger airbag on, start car again.

If not, run a diagnostic. Surely somebody in your area has planet
 
1 - 5 of 5 Posts
Top