Peugeot Forums banner

1 - 15 of 15 Posts

·
Registered
Joined
·
821 Posts
Discussion Starter #1
Hello good people of peugeotforums,

I've been having problem with aircon eversince i got the car, but recent searing hot days have prompted me to seek help. :)

First off, i believe problem not to be in cooling or heating or leaking installations, as the air coming out of vents is usualy pretty cold, certanly cold enough to cool the car down.

The actual problem i am having is actually in the volume of air coming out of vents. When i set the aircon direction arrows to side and down, to blow towards me and my legs, the volume of air coming out seems a bit low.

The aircon button for fan speed seems a bit silly too, when i set to 3 full fan blades, it blows quite slowly, not too much difference between 1, 2 or 3 levels or levels in between, but when i switch to 3.5 or 4 blades, the fan all of a sudden starts blowing quite loudly and increasing the volume quite a bit, but still its below what i would expect to be at its max.

I have also noticed that volume of air coming out of my passangers side is always somewhat lower than on my side. And when i turn on recirculation, it starts blowign quite loudly, like another fan comes on, but still volume of air seems low.

Anyone have any ideas? Could the cabin filter be plugged up or something, failed motor? Would diagnostics show up any such problem if it infact exists. How do your aircons serve you?

TL;DR My aircon seems to be blowing too low for my liking. :)

Thanks chaps,
Iva
 

·
Registered
Joined
·
1,025 Posts
I would change pollen filter passenger side footwell slides in sideways behind heater and my 407 is the same as you explained think most am but filter may help.
 
J

·
Guest
Joined
·
0 Posts
Theres a problem somewhere.... as you turn the fan speed knob up each half blade, you should hear/feel an increase in air volume - I do with mine from 1 to the full 8

Agree with Nige, check the filter first, then look to the fan motor/controller :thumb:
 

·
Registered
Joined
·
821 Posts
Discussion Starter #4
Ok, thanks guys, i will try that. So do i just need to take off A panel as show on the diagram?

I did take a quick peek to look for pollen filter when i was fiddling around with glove box compartment, but i saw nothing there. Mind you, my car is the left hand drive, or what you call it, my steering wheel is on left side. :) Im confused by the terminology. :p
 

Attachments

J

·
Guest
Joined
·
0 Posts
No need to remove Panel A.

When you find it, you will see a black plastic panel held in with a clip at one end - its about 50mmx200mm or so. Find panel A, then look upwards, right behind the console - not the easiest thing to get to.

Yours being LHD, you will gain access to it from your drivers side - I believe this wasn't swapped between LHD & RHD.
 

·
Registered
Joined
·
1,025 Posts
I never removed panel A just pulled carpet down from underneath glovebox and there is two press clips on front on the pollen filter take that off slide new one in replace plastic front.
 

·
Registered
Joined
·
821 Posts
Discussion Starter #7
Hi guys, just an update.

I pulled down the sound proofing by undoing the two plastic screws, and found the pollen filter right where you said it would be. As a bonus i took few pics for future reference for dummies like me. The filter box is actually labled pretty straightforward, its just the matter of looking at the right spot.

I proceded to take out the filter, and clean out 2 bears fur equivalent out of it. Needles to say, aircon works like the car rolled right out of factory, now at 4/8 it blows as hard as it did at full strength before cleaning, also the ugly gurgling sounds from aircon are gone. YAY! And to think that all aircon repair shops told me i need to get it refilled and whatnot for atleast 40-100EUR price. Buggers. :)

Cheers for the help guys. :thumb: You da best.


On the images the filter cap is labled FILTRATION, with some yellow stain on it, atleast on my car. One pic upclose and one a bit further away to show its exact position.
 

Attachments

·
Registered
Joined
·
16 Posts
Hello good people of peugeotforums,

I've been having problem with aircon eversince i got the car, but recent searing hot days have prompted me to seek help. :)

First off, i believe problem not to be in cooling or heating or leaking installations, as the air coming out of vents is usualy pretty cold, certanly cold enough to cool the car down.

The actual problem i am having is actually in the volume of air coming out of vents. When i set the aircon direction arrows to side and down, to blow towards me and my legs, the volume of air coming out seems a bit low.

The aircon button for fan speed seems a bit silly too, when i set to 3 full fan blades, it blows quite slowly, not too much difference between 1, 2 or 3 levels or levels in between, but when i switch to 3.5 or 4 blades, the fan all of a sudden starts blowing quite loudly and increasing the volume quite a bit, but still its below what i would expect to be at its max.

I have also noticed that volume of air coming out of my passangers side is always somewhat lower than on my side. And when i turn on recirculation, it starts blowign quite loudly, like another fan comes on, but still volume of air seems low.

Anyone have any ideas? Could the cabin filter be plugged up or something, failed motor? Would diagnostics show up any such problem if it infact exists. How do your aircons serve you?

TL;DR My aircon seems to be blowing too low for my liking. :)

Thanks chaps,
Iva
Guys,

I have the exact issue as discribed here, but there's nothing blocking the filter and even with the pollen filter I still have very poor volume of air and it's quite noisy as I can hear something blocking the air. What else can I try here?
 

·
Registered
Joined
·
4 Posts
Hi All,

I am having a simular problem . The passenger side if blowing hot and driver and rear are blowing cold even though the temp is set at hot.

Before the heating went I notice for a few weeks that after I got out of the car and with the ignition turned off, basically going into my house, the fan on the front of the car would still be running high.
 

·
Registered
Joined
·
1,073 Posts
Has been driving my dad's car a couple of days now, as I'm installing a Defa electric heating system on it.

I've noticed the right hand side only blows cold or at least quite cold air.

Is there a guide somewhere how to fix this in a proper way. I mean the complete dash-out job. I'm not keen on cutting and plastic welding, and would like to fix it properly if I'm to fix it.

So if you know if there is a step by step guide for that solution please let me know! :)
 

·
Registered
Joined
·
4 Posts
finally some truth from Dealer

I have finally got someone honest in an Irish Dealership.

The problem as shown to them is caused by a jammed heating flap.

I have been told that it is a very common problem with seemly 2007 HDI engines.

The solution is as follows;

The flap costs €70.00 + vat.

But labour is €1100.00 + vat as the whole dash etc has to come out.

And finally the best fix as advised by the dealer, wear a jacket... Love it.!!!
 

·
Registered
Joined
·
682 Posts
Common common problem. I had it go on my first 2005 407 sw then i bought a 2007 407 sw and guess what............yep its gone too. Peugeot should be put on watchdog over this as its an absolute joke but then again most car firms sell faulty crap these days so theyed need to have a program on 24 hours to day to cover all the problems. Anyway i plan on cutting into the heater box then wedging said flap on warm to get me through the winter then when the weather improves ill wedge it on cold air. Oh and i wont buy another 407 or possibly even a Peugeot again!
 

·
Registered
Joined
·
43 Posts
cabin filter

i just seen there are issues with cabin filter and that is should be replased with part number 647904 as there issues with cabin filter getting blocked fast
 
1 - 15 of 15 Posts
Top