Peugeot Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
Power steering pump on 307 Quicksilver 136 seems to have failed.

Working fine, then steering assistance off then on for a short time then off.

Peugeot Planet advises Steering ECU does not answer.

Fuses appear to be OK, Fluid Level Appears OK.

I am assuming electronics in Electric Pump have died.

Can anyone advise easiest way to access pump to remove.

I have ordered a new pump which should be coded correctly to vehicle (apparently pumps are coded according to wheel size etc, presumably to set up assistance proportional to tyre footprint etc)

Anyone got any advice on connecting new pump and establishing connection to BUS or any precautions to take to avoid knackering it before I start !!

Many thanks.

When this car goes it is OK to drive, but is the most costly per mile I have ever owned...and the biggest user of my time.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #2
Power Steering Loom Fault - Help !!

OK Tried new pump. ECU still will not answer. Assume I have a loom fault. Can anyone please give me a clue whether there is anywhere specific these looms fail. Many thanks
 

·
Registered
Joined
·
14,646 Posts
I would have looked at loom BEFORE CHANGING PUMP these pumps can fail but usually completely intermitently is nearly always down to bad signals

Check the plug check the earth to the pump check the alternator output is stable this is important as the steering ecu wants to see engine running

Do a bsi reset this usually fixes anything dodgy in our taxis including the steering missbehaving

If you have no comms then whatever is causing that is most likely ALL thats wrong
 

·
Registered
Joined
·
14 Posts
Discussion Starter #4
Electric Power Steering Intermittent Fault

Well after trying a new electric pump, reverting to the old electric pump and the vehicle either having or not having power steering. All wiring between pump and fuse box checked. Turned out to be under bonnet fuse box. This contains relays and solid state electronics and seems unfathomable. Wacking it fairly hard would sometimes bring the power steering pump back on.

Replacement of the fuse box may also have cured spurious anti pollution fault light and attempted regens which seemed to be based on spurious signals rather than any kind of true fault.

We will see.

Hope this is of use to someone pulling out their hair whilst banging head against the wall.

The fuse box is not coded to the vehicle so it is a matter of paying £140 odd quid for a new one and replacing it.
 

·
Registered
Joined
·
69 Posts
Power steering pump on 307 Quicksilver 136 seems to have failed.

Working fine, then steering assistance off then on for a short time then off.

Peugeot Planet advises Steering ECU does not answer.

Fuses appear to be OK, Fluid Level Appears OK.

I am assuming electronics in Electric Pump have died.

Can anyone advise easiest way to access pump to remove.

I have ordered a new pump which should be coded correctly to vehicle (apparently pumps are coded according to wheel size etc, presumably to set up assistance proportional to tyre footprint etc)

Anyone got any advice on connecting new pump and establishing connection to BUS or any precautions to take to avoid knackering it before I start !!

Many thanks.

When this car goes it is OK to drive, but is the most costly per mile I have ever owned...and the biggest user of my time.

any updates my friend ?
i am having the same issue :( replaced the steering pump but still no result :(
 

·
Registered
Joined
·
11 Posts
Thanks guys, was quoted 625 quid plus VAT for a new steering pump. I have had problems with the under bonnet fuse box before not any fault of Peugeot mind some idiot had drenched it with what looked like ATF. I'll give it another wash in acitone. That also helped last time with getting rid of funny fault codes
 

·
Registered
Joined
·
69 Posts
Thanks guys, was quoted 625 quid plus VAT for a new steering pump. I have had problems with the under bonnet fuse box before not any fault of Peugeot mind some idiot had drenched it with what looked like ATF. I'll give it another wash in acitone. That also helped last time with getting rid of funny fault codes

AGAIN! so it was the fuse box under the hood ?
 

·
Registered
Joined
·
11 Posts
Its fine this morning, temp dont to 8 c so must be a bad connection cause as the car heats up so the steering assistance comes and goes
 

·
Registered
Joined
·
1 Posts
Fuse box query

Hi,
Just got a 2004 307 1.6 hatchback.
After a few weeks had similar problem, power steering either on or off, no middle ground. Wiggled fuse, seems to work fine now. Better than $1850 AUD I was quoted in Sydney for new pump....
 

·
Registered
Joined
·
599 Posts
Two year old thread :D

But i concur, the bonnet fuse box, which i believe is called BSM, can give a load of trouble,and is NOT just a fuse and relay holder. There's lots of circuit there...
 
1 - 13 of 13 Posts
Top