Peugeot Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
I have a Peugeot 605, 96mod, 2l engine.

I am going to install an amp, which I have to connect to the battery...

My problem is getting trough the firewall, with the power cable. Does anyone know about a good spot? Would like to avoid to have to drill a hole:)

I appreciate any help I can get, and pictures would help a lot ;)

Best regards
Anton
 
G

·
I'm not sure on the 605, but i assume you are running this cable to your boot?

If so i'd just buy some heavier duty cable and run underneith the car

Did this on my 306, just followed the brake pipes and left a bit of spare for flexing around the back axle, never had any troubles or cut/corroded cable!

Its an option if you cant find a suitable point to go through, saves rooting around hiding cables behind panels etc as well! :)
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
Yeah, I though about it... but didn't know if it was possible. It would make things easier :) However I live in Norway and in the winter its cold here... Would that effect the amp's power supply?
 
G

·
Good question, i dont know if constant cold would damage the cables plastic covering (i wouldnt have thought so if its quite heavy duty!)

I'd see if anyone comes up with a good way through the firewall and use the underneith idea as a last resort! :thumb:
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #5 · (Edited)
I found a way through the firewall :) after some headscratching I finally found it, up under the steeringwheel it was a black rubber square that i could just poke right through... Very easy, but a little hard to see ^^

Now im all finnished and it sounds A LOT better with a sub ;)

Thanks for your help btw, any idea is a good idea. ( most of the time ;) )
 
1 - 6 of 6 Posts
Top