Peugeot Forums banner

1 - 14 of 14 Posts

·
Registered
Joined
·
32 Posts
Discussion Starter #1
Hi Everybody

I’m hoping that some of you may be able to help me with my car as I really am struggling with what to check. I have a Peugeot 307 2ltr hdi 90 on a 52 plate and runs really sluggish with hardly any turbo boost. In-fact when driving the car I carnt even hear the turbo whistle, but I can hear a slight wooosh when I change gear. When at stand-still and I rev the engine there does seem to be a slight whistle although very quiet. The car seems to be worse once it has warmed up. However she can get up to required speed when driving but I really do have to drive her hard if I want it to perform. It’s almost as if it is a non turbo car. Furthermore the car isn’t to bad on mpg, on a steady drive on motorway way still getting early 50’s mpg.
I really have no idea where to go with this as I have never owned a turbo’d car before. I have read that the egr valve can be clogged or stuck open so have bought some wynns egr3 cleaner but I believe the valve is unreachable to use this stuff (whilst still attached to engine) with as it is at the back of the engine. I was going to spray into the big air pipe after the maf sensor and see what that does. Please please can anyone help me with my car.

Kind regards
Danylar
 

·
Registered
Joined
·
22 Posts
I had a similar problem with mine today take the maf sensor out and tap any crud out of it then give it a good spray inside with the egr cleaner put back and give it a try
 

·
Registered
Joined
·
32 Posts
Discussion Starter #3
Hi Jason

I will try that tomorrow, however I have driven the car without the MAP connected and its still the same if not worse. Also I dont get the Engine fault light on when not connected, as some have reported that it comes on once disconnected. How did you get on cleaning it, did it work..

regards
Danylar
 

·
Registered
Joined
·
22 Posts
i just tapped the crud from it then got a rag on the gauze side then just give it a good spray a couple of times on the senors it seem to have worked on mine cos the turbo comes in around 2000rpm now where as before the turbo came in at 2000rpm in 1st gear then in other gears really slugish upto 3000rpm then the turbo came in just give it a try very easy job only took about 10-15 mins
 

·
Registered
Joined
·
32 Posts
Discussion Starter #5
hi Jason

Thanks for the info, i will give this a try and let you know how i get on. I gave the car a blast back from work today and it quite easily revs up to 4-5K just dnt feel any boost or sudden surge of boost and the rev increase at the same rate with no sudden surge when one would expect you would get from a turbo.

regards
danylar
 

·
Registered
Joined
·
273 Posts
the strange woosh you talk about sounds very like a split intercooler pipe which would explain the no power bit but you should be getting a bit of black smoke when you floor it if its a leak in the intercooler system
 

·
Registered
Joined
·
32 Posts
Discussion Starter #8
thanks for the input guys, it is the 90bhp and am sure it has no intercooler as carnt see one in the engine . The woosh sounds similar to a dump valve on petrol turbos when you change gear. I have no black smoke when I floor it, hoping this is a good sign.... However and I quote it is a very very quiet wooosh. Looking forward to anymore help you guys can give. Kindest regards Danylar
 

·
Registered
Joined
·
32 Posts
Discussion Starter #12
Cheers for all the replys people, a few mixed answers in regards to intercooler thou. Ive poped bonnet and I carnt see an intercooler, so I will assume mine hasnt got one.
 

·
Registered
Joined
·
2 Posts
hi danylar how are you getting on with fixing your sluggish problem as im having the exact same problem with my sisters car at the minute and im trying to get to the bottom of it.

any help would be great,

Thanks

Brett
 

·
Registered
Joined
·
29 Posts
Check and see if the turbo actuator is working (little rod operating variable vanes of turbo) it should pull down when you start the engine, I think it may be a vacuum problem
 
1 - 14 of 14 Posts
Top