Peugeot Forums banner

1 - 20 of 25 Posts

·
Registered
Joined
·
54 Posts
Discussion Starter #1
:( Just had my 1.6 16v peugeot 307 'Y' Reg in for MOT

Its failed on Anti-Lock braking system warning lamp does not Illuminate.

Removed the Clock/Cluster unit to check Bulb,, Found the Unit to be an LED Unit hence NO bulbs..

What could this Problem Be ????

Fuse (if so where abouts is the fuse)

Or do i need a new Clock Set (£370 from the main dealer ??? ) :(

PLEASE PLEASE HELP
 

·
Registered
Joined
·
9,733 Posts
Is the led damaged or removed , a cluster from a scrapyard will do as long as its from a lower mileage car than yours


Sent from my iPhone using AG Free
 

·
Registered
Joined
·
54 Posts
Discussion Starter #3
Is the led damaged or removed , a cluster from a scrapyard will do as long as its from a lower mileage car than yours


Sent from my iPhone using AG Free
Never really checked behind the cover after removing all the screws. Theres a white cover covering all the LED's so i didn't disturb it incase it all went Pete Tong
 

·
Registered
Joined
·
9,733 Posts
Wouldn't be fuse as its only the abs light , I would guess someone has tampered with it before you bought it.
Did you ever notice abs light ? How long have you had it? Wouldn't have went through last mot like that new rules or not.


Sent from my iPhone using AG Free
 

·
Registered
Joined
·
54 Posts
Discussion Starter #6 (Edited)
Wouldn't be fuse as its only the abs light , I would guess someone has tampered with it before you bought it.
Did you ever notice abs light ? How long have you had it? Wouldn't have went through last mot like that new rules or not.


Sent from my iPhone using AG Free
Had the car 2 years. Cant honestley say i've noticed ot before, On or Off ?

Passed Last MOT no prob's

In the Radio Display it Flashes up ABS Fault aswell as Anti Pollution Fault.
 

·
Registered
Joined
·
54 Posts
Discussion Starter #7
ANSWERS ON A POSTCARD PLEASE

Any input would be Appreciated, As my cars now off the Road and i have no Transport.. ( Theres me Sob Story lol )

Cheers in Advance
 

·
Registered
Joined
·
9,733 Posts
So it's been flashing this up how long ? Sorry if it sounds if I'm pulling teeth but all info is needed to try and help as we don't see the car.


Sent from my iPhone using AG Free
 

·
Registered
Joined
·
535 Posts
So, the ABS light does not work at all? Sounds like the previous owner had trouble with it coming on and programmed it out with Peugeot Planet Diagnostics.

If that had been done, it needs PP re-attaching and seeing what's going on.
 

·
Registered
Joined
·
16 Posts
covering up led light

i was in the car trade for 10 years and i heard that there were people covring lights up ,they would take bulbs out before but the led lights as you know are harder,they simply cover them up with black masking tape or something , ive heard a few people that have done it,also re wiring dash so light comes on for so long then off to pass mot etc
but dont really know the in's and out's of how they do it,prob last owner
 

·
Registered
Joined
·
4,506 Posts
check the solder on the relevant LED...does it look professional like the others or is there noticable differences?

as mentioned by richhall, also check the inside of the cluster for any tape covering.
 

·
Registered
Joined
·
9,733 Posts
So, the ABS light does not work at all? Sounds like the previous owner had trouble with it coming on and programmed it out with Peugeot Planet Diagnostics.

If that had been done, it needs PP re-attaching and seeing what's going on.
You can`t program a ABS light out , its a safety feature so can`t be done :nono:
 

·
Moderator
Joined
·
5,836 Posts
Have not look at the electrical connector on a 307 pump, but on most vehicles (and all bosch units i have worked on) there is a shorting link in the abs pump connector which puts the abs light on if the pump is unplugged. This can often be used as a quicjk check to confirm the wiring from pump to dash and dash light work and identify a possible faulty abs pump ecu. If you unplug pump dash light should illuminate if wiring and plug are OK
 

·
Registered
Joined
·
54 Posts
Discussion Starter #14
So it's been flashing this up how long ? Sorry if it sounds if I'm pulling teeth but all info is needed to try and help as we don't see the car.


Sent from my iPhone using AG Free
OKEY DOKEY :

Never really noticed if ABS light on dash has or hasn't worked ?

On the LCD / Radio Display ever since i got it (2 years) its flashed up ABS Fault when i start the Vehicle. Heard this is a common Fault so never done anything about it. About 2 weeks ago it flashed up (while Driving) STOP BRAKE FAULT. I turned off ignition, Then back on and it went :eek:. That fault Pops up every now and again.

It also has ' ANTI POLUTION FAULT ' Flashing up. ( About a Year now )

TEMP GUAGE dosen't work (never has)

And just Recently i'm getting 'ENGINE COOLANT TEMP TO HIGH' after only driving 5 minutes????

Removed Clocks yesterday to find sealed LED unit. Fitted clocks back and now the Temperature Guage Works lol...

Headlight Locators were all smashed, So i bonded them it and Realligned them for the MOT (passed)

WHAT HAVE I BOUGHT
 

·
Registered
Joined
·
3,426 Posts
hi all. how does the mot know it doesnt work?

i had an abs fault on mine but never seen a abs light. where is this located. i only tested the abs worked when i changed the discs but didnt notice anything off hand but i didnt really look
 

·
Registered
Joined
·
586 Posts
Yes it should. Anyway all the big ABS fuses are located under the engine compartment fuse box. Has this vehicle got a relay located on the plastic in front of the ecu??
 
S

·
Guest
Joined
·
0 Posts
Sounds to me like a cover up job by previous owner

But with all your faults, especially the braking system ones, get it on diag to be safe!!

its NEVER worth scrimping or ignoring braking system faults in any circumstances!
 

·
Registered
Joined
·
209 Posts
I ended up replacing all my wheel bearings on my 307 fixing the ABS fault, one went then the next then the next. They arent hard to change.

That will fix the fault....


Also did you take your car to your local garage or Kwik-fitup as they will fail it for driving on cracks on the road so they can charge you for fixing it! I pay a little more at my local garage and it passes no problems, everytime i went for a 'half price' deal it cost me way more than my local independent.
 
1 - 20 of 25 Posts
Top