Peugeot Forums banner

1 - 20 of 24 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
Good day everyone, so I have a Peugeot 307 1.6 16v 2005 my car just left me and my family stranded on the freeway one day, about three months ago car has been standing ever since had two diagnostics done, changed my crankshaft sensor as diagnostics Said it's a permanent fault car still didn't start tested ecu, bsi and key , they said ecu is busted so I had the ecu , bsi and key programmed car still won't start...my doors don't lock Windows don't work lock button light is flashing rapidly there is no beep on the whilst in ignition on the dash console it says eco mode active...I tried bsi reset, key reset and to kick it out eco mode with a wire from positive terminal to starter...PLEASE HELP.
 

·
Moderator
Joined
·
2,624 Posts
Start by checking all the fuses..eco mode as said will not stop it starting but will dissable some electrics (its trying to save the battery )..check battery voltage...the beep test would be the first thing sort out....
 

·
Registered
Joined
·
12 Posts
Discussion Starter #4
I bought a new battery, I'm currently waiting on the key and receiver to come back today...but I have a feeling it won't start still, if that doesn't work do you think I should try the Jul I emulator immo off?

I appreciate your response and help
 

·
Registered
Joined
·
14,961 Posts
You need to do more reading you are not helping by blaming parts that have nothing to do with issue there is plenty of non start info on the forum telling you what you SHOULD be checking its never the ecu.

It was not the key either but it might be now due to the battery disconnection testing etc

Beep test FIRST no beep no start simple as that but getting to that point only fixes what you have already broken it still wont start till you find the original fault my guess is timing belt !
 

·
Registered
Joined
·
12 Posts
Discussion Starter #6
My timing belt is intact...the motor turns over just doesn't start...there is no beep whilst key is in also all earth contacts are corrosion free, I cleaned it already as well just to double check, we also checked wired continuity from most important parts all seems fine
 

·
Registered
Joined
·
14,961 Posts
The lack of the beep is the issue NOW but that would not have caused initial cutting out
As i say you have more than 1 issue

You say belt intact does engine spin over really fast ?
 

·
Registered
Joined
·
12 Posts
Discussion Starter #9
Good day, yes the engine cranks fast and strong...my fuel pump doesn't switch on, also there is no fire we tested the multiplug that goes into the coilpack...there's no power coming through
 

·
Registered
Joined
·
14,961 Posts
Cranks fast and strong is worrying how did you check the belt please explain.

Fuel pump should prime at key on for a few seconds then stop till engine is cranking
 

·
Registered
Joined
·
12 Posts
Discussion Starter #11
Please helpi

I took the engine mounting off and then the timing belt cover, belt is good, when I do turn the key I can hear the noise it makes when it primes bit no fuel comes through to valve in front when I check for fuel...when the car switched off it went dead then I kicked it and died again then I kicked it to start again in the drive...then stopped altogether.
 

·
Registered
Joined
·
14,961 Posts
lock button flashing rapid is to do with alarm i believe its just saying alarm has been triggered but i just want to be sure about the belt first as all your symptoms could be because the engine is not starting not THE CAUSE.

So you looked at the belt and concluded its ok because its still on the pulleys you NEED to check its still timed as belts dont always break sometimes they jump teeth strip a few teeth off but still look ok.

Have you checked you HAVE fuel dont believe the gauge.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #15
I have checked the fuel, I opened the tank to test the fuel pump there is more then enough fuel in it, also we checked the timing everything is in order.
 

·
Registered
Joined
·
14,961 Posts
Ok we will assume your engine is OK

Beep test again the key MUST be recognised to allow starting if your doing beep test correctly and its not beeping then it will not start

Explain what was done to code key
 

·
Registered
Joined
·
12 Posts
Discussion Starter #18
The key bsi ecu key and key reader was taken in to be tested, came back saying the key transponder and key reader is working but the ecu was busted so they coded a new ecu to work with the bsi and key etc but car still didn't start...so now I'm wondering if I shouldn't do the immo off
 

·
Registered
Joined
·
14,961 Posts
Regardless of all that the car needs to see the key as if its not seeing the key there is something not powered or similar and that is what made it cut out.

With the uncertainty of what is really wrong i doubt a de immobilised ecu will work either.

ECUs rarely break so i doubt that diagnosis to be honest.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #20
Hi everyone so the immo off works, however it only starts and idles if fuel is thrown directly into the throttle body...also it exited economy mode but now when i play the radio it makes a beep sound...any thoughts?
 
1 - 20 of 24 Posts
Top