Peugeot Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
54 Posts
Discussion Starter #1
I have recently purchased a 'Y' Reg Peugeot 307 1.6 16v. It has a few Faults.

1) Temperature Gauge not working.
2) Horn only works when it wants to. Fits and Starts.
3) Key dosen't work when i press the remote, (changed batterys on both)

& Finally just recently more concerning fault:
When foot on accelerater mainly at high Revs there is a strange Buzzing/Wirring Noise (Similar sound to when Reversing ?) which when revs get higher noise gets louder but as soon as i take foot off accelerator it stops.. Any ideas anyone.

Cheers
 

·
Registered
Joined
·
54 Posts
Discussion Starter #2
Forgot

Also the ASB fault light is on (Common i've been told) But every now and again it flashes BRAKE FAULT and STOP flashes up on dash, Turn ignition off then back on again and the Fault dissapears ??
 

·
Moderator
Joined
·
11,706 Posts
You'll be pleased to know that they're common faults.

1) Faulty temperature sensor. About £12 from Peugeot.

2) Bad earth or other maintenance issue due to difficult to reach location of horn. Or could be faulty switch on the steering wheel.

3) Re-sync key?

4)

5) ABS. Sensor gap. Remove wheels, remove sensors and clean the metal area it mounts to. Reattach and ensure that the gap is 2mm.
 

·
Registered
Joined
·
54 Posts
Discussion Starter #4
You'll be pleased to know that they're common faults.

1) Faulty temperature sensor. About £12 from Peugeot. I'll look into this thanks.

2) Bad earth or other maintenance issue due to difficult to reach location of horn. Or could be faulty switch on the steering wheel.(It worked fine when key remote worked or when i lock it twice)

3) Re-sync key? (How Exactly,)
4) :confused:

5) ABS. Sensor gap. Remove wheels, remove sensors and clean the metal area it mounts to. Reattach and ensure that the gap is 2mm.(Again Thanks i'll look into this. Pleased its nowt major.)
Cheers for all your advice mate. I will look into it
 
1 - 4 of 4 Posts
Top