Peugeot Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
So i am quite lost right now...

Car runs fine at 90c on flat ground up to 50 km/h. After that the temp starts climbing to 100c at 70 km/h And finaly 80-90 km/h it peaks at roughly 109c, never going all the way red.

Uphill is pretty much 90c-109c in 30-40 secs.

Changed the thermostat (boiled it in water with a temp gauge to make sure it worked. Starts opening at 88c as indicated on the thermostat)

Recently changed all fluids and timing belt+water pump at a Peugot certified workshop. Also asked him to check if the fans were operating properly, which he said they do. (They kick in at around 100-105c and run for aprox 10 seconds before powering off...?)

Flushed the radiator with the garden hose method, since the cooling fluid pretty much looked like a orange rust soup... took 3 flushing cycles until pretty much only clear water came out of the radiator drain. The reservoir tank did seem kinda clogged, cause the flow would stop and i had to lightly hit the reservoir to make the water move again.

Refilled with coolant, bled out the air etc, but the problem persists... I did notice something odd after the first run tho.. temp was at roughly 105c and i opened the bleed valve just to check that coolant was flowing, but it didn't until the engine hit about 95c. Was that just a large amount of air trapped or is there a circulation problem here?

I'm pretty new to car repairs, so any help would be greatly appreciated.
 

·
Registered
Joined
·
1,133 Posts
Could be that your radiator is partially blocked with gunge so is unable to cool when under load. Your description of 'orange rust soup' is a giveaway... ;)

Easy way to check for blockages is to use one of these contactless infra red thermometers and aim it at various points across the surface of the radiator when the car is at operating temperature and see if there is any significant difference in readings across the face between the hottest and coldest measured temp. Blocked areas will display as being much colder than working areas.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Thanks for the insight.

Think buying a bottle of radiator cleaner and trying another flush should solve it?
Guessing just using water doesn't really get out all the gunge..
 

·
Registered
Joined
·
1,133 Posts
In my experience, radiator flush seldom cures a blocked radiator as the flush only works by flowing over the surface and dissolving/loosening the gunge. Blocked tubes dont allow flow so only the very end of the blockage is attacked and there is no flow to flush the sediment away.

The infra red devices are cheap on ebay, testing will quickly tell if the radiator is working properly or not. Most garages will have one also, try the one who did your recent belt/pump?
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5 (Edited)
Allright thanks a lot! I will have them take a look at it... at least having the problem narrowed down a bit will save me some money, hopefully.
 

·
Registered
Joined
·
901 Posts
In my experience, radiator flush seldom cures a blocked radiator as the flush only works by flowing over the surface and dissolving/loosening the gunge. Blocked tubes dont allow flow so only the very end of the blockage is attacked and there is no flow to flush the sediment away.

The infra red devices are cheap on ebay, testing will quickly tell if the radiator is working properly or not. Most garages will have one also, try the one who did your recent belt/pump?
Agree,rad flush just keeps good rads clean.
It's highly likely that it's the original radiator,so at 19 years old it's time to replace it.
While the rad is out stick a pipe up the rad hoses and give the cylinder block a good flush out.
 

·
Registered
Joined
·
13 Posts
I just retrieved my 306 from the shop for cooling issues among others. It seems common for Peugeots or at least 306s.

Last winter I made the mistake of going in the shop for cooling system cleaning. From the pressure and the cleaner, it unclogs all of the cracks in the system and it causes more problems than it solves. Turns out I had a cracked heater radiator and a bad water pump. I had almost the entire cooling system rebuild. And it even still, driving in the city in the heats gets the temp to about 95-100C, the fan kicks in and lowers it back to 90C. Again and again.

Not sure if that's normal but considering the age of the car and how small the radiator is, I assume it can be.
 

·
Registered
Joined
·
1,125 Posts
I had almost the entire cooling system rebuild. And it even still, driving in the city in the heats gets the temp to about 95-100C, the fan kicks in and lowers it back to 90C. Again and again.

Not sure if that's normal but considering the age of the car and how small the radiator is, I assume it can be.
Perfectly normal :thumb:. your cooling fan is doing exactly what it is supposed to do.

To address the op, replace the radiator, fill it with a 50% mix of the correct antifreeze, and forget about cooling system woes. :)

Roger.
 
1 - 8 of 8 Posts
Top